WARNING: Could not find logstash.yml which is typically located in $LS_HOME/config or /etc/logstash


(Sayed Mohamed) #1

i have a problem that i run file as command : sudo bin/logstash --path.data sensor38 -f /home/sayed/logstash/sayed.conf
and i have an warning that i set some configuration on it
WARNING: Could not find logstash.yml which is typically located in $LS_HOME/config or /etc/logstash. You can specify the path using --path.settings. Continuing using the defaults
Could not find log4j2 configuration at path /usr/share/logstash/config/log4j2.properties. Using default config which logs errors to the console
so i need help and i did every thing that related this topic but no vain


(Magnus Bäck) #2

Did you try using the --path.settings option to point to the directory where logstash.yml resides? If you run an RPM- or Debian-based distribution I recommend you use the packages instead of downloading the tarball (which seems to be what you've done).


(Sayed Mohamed) #3

yes . i used it and i got this error ERROR: Unrecognised option '--path.settings.'


#4

can you please post the command you use and the error please when you use -path.settings?


(Sayed Mohamed) #5

WARNING: Could not find logstash.yml which is typically located in $LS_HOME/config or /etc/logstash. You can specify the path using --path.settings. Continuing using the defaults
ERROR: Unrecognised option '--path.settings.'

See: 'bin/logstash --help'
[ERROR] 2018-05-09 09:48:58.104 [main] Logstash - java.lang.IllegalStateException: org.jruby.exceptions.RaiseException: (SystemExit) exit


#6

and the COMMAND you used?


(Sayed Mohamed) #7

sudo bin/logstash --path.settings. /etc/logstash --path.data sensor39 -f /home/sayed/logstash/sayed.conf


#8

try with this

sudo bin/logstash --path.settings /etc/logstash/ --path.data sensor39 -f /home/sayed/logstash/sayed.conf


(Sayed Mohamed) #9

i get
ERROR: Failed to parse YAML file "/etc/logstash/logstash.yml". Please confirm if the YAML structure is valid (e.g. look for incorrect usage of whitespace or indentation). Aborting... parser_error=>(): expected , but found BlockMappingStart while parsing a block mapping at line 41 column 2
[ERROR] 2018-05-09 10:19:32.813 [main] Logstash - java.lang.IllegalStateException: org.jruby.exceptions.RaiseException: (SystemExit) exit


#10

Show me your logstash.yml configuration. I have to say that imnot an expert so i will do my best :confused:


(Sayed Mohamed) #11

Settings file in YAML

Settings can be specified either in hierarchical form, e.g.:

pipeline:

batch:

size: 500

delay: 5

Or as flat keys:

pipeline.batch.size: 500

pipeline.batch.delay: 5

------------ Node identity ------------

Use a descriptive name for the node:

node.name: test

If omitted the node name will default to the machine's host name

------------ Data path ------------------

Which directory should be used by logstash and its plugins

for any persistent needs. Defaults to LOGSTASH_HOME/data

path.data: /var/lib/logstash

------------ Pipeline Settings --------------

The ID of the pipeline.

pipeline.id: main

Set the number of workers that will, in parallel, execute the filters+outputs

stage of the pipeline.

This defaults to the number of the host's CPU cores.

pipeline.workers: 10

How many events to retrieve from inputs before sending to filters+workers

pipeline.batch.size: 125

How long to wait in milliseconds while polling for the next event

before dispatching an undersized batch to filters+outputs

pipeline.batch.delay: 50

Force Logstash to exit during shutdown even if there are still inflight

events in memory. By default, logstash will refuse to quit until all

received events have been pushed to the outputs.

WARNING: enabling this can lead to data loss during shutdown

pipeline.unsafe_shutdown: false

------------ Pipeline Configuration Settings --------------

Where to fetch the pipeline configuration for the main pipeline

path.config:

Pipeline configuration string for the main pipeline

config.string:

At startup, test if the configuration is valid and exit (dry run)

config.test_and_exit: false

Periodically check if the configuration has changed and reload the pipeline

This can also be triggered manually through the SIGHUP signal

config.reload.automatic: false

How often to check if the pipeline configuration has changed (in seconds)

config.reload.interval: 3s

Show fully compiled configuration as debug log message

NOTE: --log.level must be 'debug'

config.debug: false

When enabled, process escaped characters such as \n and " in strings in the

pipeline configuration files.

config.support_escapes: false

------------ Module Settings ---------------

Define modules here. Modules definitions must be defined as an array.

The simple way to see this is to prepend each name with a -, and keep

all associated variables under the name they are associated with, and

above the next, like this:

modules:

- name: MODULE_NAME

var.PLUGINTYPE1.PLUGINNAME1.KEY1: VALUE

var.PLUGINTYPE1.PLUGINNAME1.KEY2: VALUE

var.PLUGINTYPE2.PLUGINNAME1.KEY1: VALUE

var.PLUGINTYPE3.PLUGINNAME3.KEY1: VALUE

Module variable names must be in the format of

var.PLUGIN_TYPE.PLUGIN_NAME.KEY

modules:

------------ Cloud Settings ---------------

Define Elastic Cloud settings here.

Format of cloud.id is a base64 value e.g. dXMtZWFzdC0xLmF3cy5mb3VuZC5pbyRub3RhcmVhbCRpZGVudGlmaWVy

and it may have an label prefix e.g. staging:dXMtZ...

This will overwrite 'var.elasticsearch.hosts' and 'var.kibana.host'

cloud.id:

Format of cloud.auth is: :

This is optional

If supplied this will overwrite 'var.elasticsearch.username' and 'var.elasticsearch.password'

If supplied this will overwrite 'var.kibana.username' and 'var.kibana.password'

cloud.auth: elastic:

------------ Queuing Settings --------------

Internal queuing model, "memory" for legacy in-memory based queuing and

"persisted" for disk-based acked queueing. Defaults is memory

queue.type: memory

If using queue.type: persisted, the directory path where the data files will be stored.

Default is path.data/queue

path.queue:

If using queue.type: persisted, the page data files size. The queue data consists of

append-only data files separated into pages. Default is 64mb

queue.page_capacity: 2gb

If using queue.type: persisted, the maximum number of unread events in the queue.

Default is 0 (unlimited)

queue.max_events: 0

If using queue.type: persisted, the total capacity of the queue in number of bytes.

If you would like more unacked events to be buffered in Logstash, you can increase the

capacity using this setting. Please make sure your disk drive has capacity greater than

the size specified here. If both max_bytes and max_events are specified, Logstash will pick

whichever criteria is reached first

Default is 1024mb or 1gb

queue.max_bytes: 150gb

If using queue.type: persisted, the maximum number of acked events before forcing a checkpoint

Default is 1024, 0 for unlimited

queue.checkpoint.acks: 1024

If using queue.type: persisted, the maximum number of written events before forcing a checkpoint

Default is 1024, 0 for unlimited

queue.checkpoint.writes: 1024

If using queue.type: persisted, the interval in milliseconds when a checkpoint is forced on the head page

Default is 1000, 0 for no periodic checkpoint.

queue.checkpoint.interval: 1000

------------ Dead-Letter Queue Settings --------------

Flag to turn on dead-letter queue.

dead_letter_queue.enable: false

If using dead_letter_queue.enable: true, the maximum size of each dead letter queue. Entries

will be dropped if they would increase the size of the dead letter queue beyond this setting.

Default is 1024mb

dead_letter_queue.max_bytes: 1024mb

If using dead_letter_queue.enable: true, the directory path where the data files will be stored.

Default is path.data/dead_letter_queue

path.dead_letter_queue:

------------ Metrics Settings --------------

Bind address for the metrics REST endpoint

http.host: "127.0.0.1"

Bind port for the metrics REST endpoint, this option also accept a range

(9600-9700) and logstash will pick up the first available ports.

http.port: 9600-9700

------------ Debugging Settings --------------

Options for log.level:

* fatal

* error

* warn

* info (default)

* debug

* trace

log.level: info

path.logs: /var/log/logstash

------------ Other Settings --------------

Where to find custom plugins

path.plugins: []


#12

Can you do this and then try to use the command again?

service logstash stop
service logstash start
service logstash status -l

And this:

systemctl stop logstash.service
systemctl start logstash.service
systemctl status logstash.service -l

If it shows any error while you do the status command post it here :stuck_out_tongue:


#13

Or you can just comment this part, and work with the defaults settings; is that ok?

------------ Pipeline Settings --------------
The ID of the pipeline.
pipeline.id: main
Set the number of workers that will, in parallel, execute the filters+outputs
stage of the pipeline.
This defaults to the number of the host's CPU cores.
###pipeline.workers: 10### <-- [THIS ONE]
How many events to retrieve from inputs before sending to filters+workers
pipeline.batch.size: 125


(Sayed Mohamed) #14

but commands that i have run before i got this

WARNING: Could not find logstash.yml which is typically located in $LS_HOME/config or /etc/logstash. You can specify the path using --path.settings. Continuing using the defaults
Could not find log4j2 configuration at path /usr/share/logstash/config/log4j2.properties. Using default config which logs errors to the console


#15

the problem there is that when you used the coomand you left this: [ / ] and you have to delete the [ . ] of the path settings in your command.

sudo bin/logstash --path.settings. /etc/logstash --path.data sensor39 -f /home/sayed/logstash/sayed.conf

it's not like that.

it's like this:

sudo bin/logstash --path.settings /etc/logstash/ --path.data sensor39 -f /home/sayed/logstash/sayed.conf

And please post the /etc/logstash/log4j2 configuration


(Sayed Mohamed) #16

i have already run last command not first
ok i'll post that


(Sayed Mohamed) #17

status = error
name = LogstashPropertiesConfig

appender.rolling.type = RollingFile
appender.rolling.name = plain_rolling
appender.rolling.fileName = ${sys:ls.logs}/logstash-${sys:ls.log.format}.log
appender.rolling.filePattern = ${sys:ls.logs}/logstash-${sys:ls.log.format}-%d{yyyy-MM-dd}.log
appender.rolling.policies.type = Policies
appender.rolling.policies.time.type = TimeBasedTriggeringPolicy
appender.rolling.policies.time.interval = 1
appender.rolling.policies.time.modulate = true
appender.rolling.layout.type = PatternLayout
appender.rolling.layout.pattern = [%d{ISO8601}][%-5p][%-25c] %-.10000m%n

appender.json_rolling.type = RollingFile
appender.json_rolling.name = json_rolling
appender.json_rolling.fileName = ${sys:ls.logs}/logstash-${sys:ls.log.format}.log
appender.json_rolling.filePattern = ${sys:ls.logs}/logstash-${sys:ls.log.format}-%d{yyyy-MM-dd}.log
appender.json_rolling.policies.type = Policies
appender.json_rolling.policies.time.type = TimeBasedTriggeringPolicy
appender.json_rolling.policies.time.interval = 1
appender.json_rolling.policies.time.modulate = true
appender.json_rolling.layout.type = JSONLayout
appender.json_rolling.layout.compact = true
appender.json_rolling.layout.eventEol = true

rootLogger.level = ${sys:ls.log.level}
rootLogger.appenderRef.rolling.ref = ${sys:ls.log.format}_rolling


(Sayed Mohamed) #18

when i run this command : sudo bin/logstash --path.settings /etc/logstash/ --path.data sensor39 -f /home/sayed/logstash/sayed.conf

i still get this : ERROR: Failed to parse YAML file "/etc/logstash/logstash.yml". Please confirm if the YAML structure is valid (e.g. look for incorrect usage of whitespace or indentation). Aborting... parser_error=>(): expected , but found BlockMappingStart while parsing a block mapping at line 41 column 2
[ERROR] 2018-05-09 11:05:17.264 [main] Logstash - java.lang.IllegalStateException: org.jruby.exceptions.RaiseException: (SystemExit) exit


#19

I don't know what happends there; maybe @magnusbaeck or @Christian_Dahlqvist help you I don't know much about that, sorry @sayed_mohamed


(Magnus Bäck) #20

ERROR: Failed to parse YAML file "/etc/logstash/logstash.yml". Please confirm if the YAML structure is valid (e.g. look for incorrect usage of whitespace or indentation). Aborting... parser_error=>(): expected , but found BlockMappingStart while parsing a block mapping at line 41 column 2

Clearly there's a problem with your logstash.yml, probably in the vicinity of line 41. Post the file again and format it as preformatted text using markdown syntax or the </> toolbar button.