"LogStash::ConfigurationError"


(emma) #1

Here is my config file of logstash for sending data from MYSQL to Kibana

input {
jdbc {
sincedb_path => "/dev/null"
ignore_older => 0
jdbc_driver_library => "ELK/logstash-6.2.3/logstash-6.2.3/bin/mysql-connector-java-5.1.47-bin.jar"
jdbc_driver_class => "com.mysql.jdbc.Driver"
jdbc_connection_string => "jdbc:mysql://localhost:3306/data"
jdbc_user => "root"
jdbc_password => password"
statement => "select * from tbl_chatbot_answers"
clean_run => true

}
}

filter {
mutate { convert => {"answer_id" => "integer"} }
mutate { convert => {"rstatus" => "integer"} }
}
output{
elasticsearch {
hosts => ["localhost:9200"]
index => "crowdsourcing"
}
stdout { codec => rubydebug { metadata => true } }

stdout { codec => dots }

}

Im getting the below error

"LogStash::ConfigurationError", :message=>"Something is wrong with your configuration.", :backtrace=>["C:/ELK/logstash-6.2.3/logstash-6.2.3/logstash-core/lib/logstash/config/mixin.rb:89:in config_init'", "C:/ELK/logstash-6.2.3/logstash-6.2.3/logstash-core/lib/logstash/inputs/base.rb:62:ininitialize'", "C:/ELK/logstash-6.2.3/logstash-6.2.3/logstash-core/lib/logstash/plugins/plugin_factory.rb:89:in plugin'", "C:/ELK/logstash-6.2.3/logstash-6.2.3/logstash-core/lib/logstash/pipeline.rb:112:inplugin'", "(eval):8:in <eval>'", "org/jruby/RubyKernel.java:994:ineval'", "C:/ELK/logstash-6.2.3/logstash-6.2.3/logstash-core/lib/logstash/pipeline.rb:84:in initialize'", "C:/ELK/logstash-6.2.3/logstash-6.2.3/logstash-core/lib/logstash/pipeline.rb:169:ininitialize'", "C:/ELK/logstash-6.2.3/logstash-6.2.3/logstash-core/lib/logstash/pipeline_action/create.rb:40:in execute'", "C:/ELK/logstash-6.2.3/logstash-6.2.3/logstash-core/lib/logstash/agent.rb:315:inblock in converge_state'", "C:/ELK/logstash-6.2.3/logstash-6.2.3/logstash-core/lib/logstash/agent.rb:141:in with_pipelines'", "C:/ELK/logstash-6.2.3/logstash-6.2.3/logstash-core/lib/logstash/agent.rb:312:inblock in converge_state'", "org/jruby/RubyArray.java:1734:in each'", "C:/ELK/logstash-6.2.3/logstash-6.2.3/logstash-core/lib/logstash/agent.rb:299:inconverge_state'", "C:/ELK/logstash-6.2.3/logstash-6.2.3/logstash-core/lib/logstash/agent.rb:166:in block in converge_state_and_update'", "C:/ELK/logstash-6.2.3/logstash-6.2.3/logstash-core/lib/logstash/agent.rb:141:inwith_pipelines'", "C:/ELK/logstash-6.2.3/logstash-6.2.3/logstash-core/lib/logstash/agent.rb:164:in converge_state_and_update'", "C:/ELK/logstash-6.2.3/logstash-6.2.3/logstash-core/lib/logstash/agent.rb:90:inexecute'", "C:/ELK/logstash-6.2.3/logstash-6.2.3/logstash-core/lib/logstash/runner.rb:348:in block in execute'", "C:/ELK/logstash-6.2.3/logstash-6.2.3/vendor/bundle/jruby/2.3.0/gems/stud-0.0.23/lib/stud/task.rb:24:inblock in initialize'"]}


(Magnus B├Ąck) #2

Start by removing the sincedb_path option from your jdbc input. I also recommend that you use an absolute path in the jdbc_driver_library option.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.