Logstash doesn't index all files in a folder

Hello All, I am new to Elastic Stack and have been working on it for last 2 weeks. I am facing an issue with Logstash where I am reading log files from a specific folder. But when I tried to find some data on Kibana, I observed that some files got skipped. When I ran them individually, they all indexed fine. I need Logstash to pick up and index all files correctly, can someone help me?
I am using: elasticsearch-6.5.1, kibana-6.5.2, logstash-6.5.1 on Windows Machine
input {
file {
path => "C:/Users/s5tn7jp/LogMonitoring/logs/*"
type => "marketshare"
start_position => "beginning"

filter { kv { field_split_pattern => " " } }

output {
elasticsearch {
hosts => ["http://localhost:9200"]
index => "logstash"
stdout { codec => rubydebug }}
Log:: time='2018-12-11T05:04:38,188' type='VERBOSE' code='103024' target='TestServer' methodName='Draw' machine='DEV.PORTFOLIO.COM' process='18819' thread='508' user='sstyu2' elapsed='0.09941' Message: Access

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.