Logstash:ERROR][logstash.config.sourceloader


(RL) #1

Not able to push the data through logstash. Getting below error.

[2018-10-27T22:00:34,851][INFO ][logstash.modules.scaffold] Initializing module {:module_name=>"fb_apache", :directory=>"C:/logstash/modules/fb_apache/configuration"}
[2018-10-27T22:00:34,869][INFO ][logstash.modules.scaffold] Initializing module {:module_name=>"netflow", :directory=>"C:/logstash/modules/netflow/configuration"}
[2018-10-27T22:00:35,098][WARN ][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified
[2018-10-27T22:00:35,688][INFO ][logstash.runner ] Starting Logstash {"logstash.version"=>"6.2.2"}
[2018-10-27T22:00:35,834][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.
[2018-10-27T22:00:36,102][INFO ][logstash.agent ] Successfully started Logstash API endpoint {:port=>9600}


(Magnus Bäck) #2

How are you starting Logstash? What are the non-comment lines of your logstash.yml?


(RL) #3

Thanks Magnus for immediate reply.
I was running previous version i.e. 6.2.2 ,so uninstalled it. After that installed 6.4 version again. First ran simple conf file. After that loaded my data. It is successful.

My date fields are loading as string only. Is there any issue with below line in conf ?

     			date {
            match => ["CREATIONDATE","DD/MM/yyyy hh:mm:ss" ]
                                    }

The above format matches in CSV file.


(Magnus Bäck) #4

Which field did you expect to become a date?


(RL) #5

3 fields as you see below : CREATIONDATE, RESOLUTIONDATE, CLOSUREDATE

 filter {
     csv{
	     
		    separator => ","
			columns => ["Assignee", "ResourceType", "Level", "PARTITIONLEAD", "RESOURCESTATUS", "EMEAACHARGEDTOMX", "NOTGBSPL", "SFWFACTMEMBER", "RFSRESOURCE", "PARTITION", "WORKGROUP", "WORKGROUPID", "SERVICEID", "SERVICETYPE", "SERVTYPETVUS", "TICKETDESCRIPTION", "TICKETSOLUTION", "TICKETLANGUAGE", "CREATIONDATE", "RESOLUTIONDATE", "CLOSUREDATE", "AFFECTEDPERSON", "AFFECTEDCOUNTRY", "AFFECTEDREGION", "SLA", "RESOURCEMGMTREGION", "COUNTRYGETTINGTVUs", "COUNTRYPL", "REGIONPL"]
		}	

    		 	date {
           match => ["CREATIONDATE","DD/MM/yyyy" ]
			target => "CREATIONDATE"
             }
			 
       			date {
            match => ["RESOLUTIONDATE","DD/MM/yyyy" ]
			target => "RESOLUTIONDATE"

           }
			 date {
           match => ["CLOSUREDATE","DD/MM/yyyy" ]
			target => "CLOSUREDATE"

(RL) #6

Changed the date format as per Kibana advance setting and it worked. Thanks


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.