Logstash fails with error on logstash-core-plugin-api.gemspec

I updated our logstash to use OpenJDK11 and it was working fine for a few days. Then logs files grew too big and disk space got eaten. I removed the extra log files, turned down the log level and still getting this error:

Apr 01 12:49:51 ip-161-161-0-196 logstash[17272]: [ERROR] 2020-04-01 12:49:51.578 [main] Logstash - java.lang.IllegalStateException: Logstash stopped processing because of an error: (GemspecError)
Apr 01 12:49:51 ip-161-161-0-196 logstash[17272]: [!] There was an error while loading `logstash-core-plugin-api.gemspec`: load error: psych -- java.lang.RuntimeException: BUG: we can not copy embedded jar to temp directory
Apr 01 12:49:51 ip-161-161-0-196 logstash[17272]: Does it try to require a relative path? That's been removed in Ruby 1.9. Bundler cannot continue.
Apr 01 12:49:51 ip-161-161-0-196 systemd[1]: logstash.service: Main process exited, code=exited, status=1/FAILURE

I did an apt install jruby and then tried to get gemspec, but it is looking for it in Java8 which I uninstalled already:

ubuntu:~$ jruby -S gem install logstash-core-plugin-api.gemspec
/usr/bin/jruby: line 418: /usr/lib/jvm/java-8-oracle/bin/java: No such file or directory

I tried multiple reboot all to no avail - got any thoughts?
logstash 6.8.7
Platform Ubuntu 18.04.4 LTS
Java OpenJDK 64-Bit Server VM (build 11.0.6+10-post-Ubuntu-1ubuntu118.04.1, mixed mode, sharing)

Finally got it working by uninstalling ruby and logstash, and then reinstalling logstash package again.
Don't know what caused it to break in the first place, so I will just have to monitor and make sure it remains stable for a few weeks.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.