Logstash file plugin on windows

I've just installed logstach version 8.9.2 on windows and tried to do first file sample but I am greeting message=>"Unable to configure plugins: (PluginLoadingError) Couldn't find any input plugin named 'file'

I insured that file plugin is installed and i reinstalled it but getting same error

Can you show your .conf file?

# Sample Logstash configuration for creating a simple

input {
  file {
   path=> "D:/log/*.log"
   start_position => "beginning"

output {
  elasticsearch {
    hosts => ["http://localhost:9200"]
    index => "cate-%{+YYYY.MM.dd}"

Conf looks OK.
Check does the file plugin exist:

logstash-plugin list

If is missing, try to download LS again. For sure LS 8.9.2 is working on Windows.

this is print screen for listed plugins and the error

You should have the logstash\vendor\bundle\jruby\2.6.0\gems\logstash-input-file-4.4.4 directory with 45 files, 12 subolders. Check it pls.

Yes the directory exists with 45 files and 12 subfolders

This looks like Powershell without admin rights.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.