Logstash-filter-elasticsearch plugin not installing


When trying to install the logstash-filter-elasticsearch plugin (v3.1.4) I get the below exception:
I have tried installing the zip and the gem file. My logstash version is 5.4.0.

java/util/Hashtable.java:459:in put': java.lang.NullPointerException from java/util/Properties.java:166:insetProperty'
from java/lang/System.java:796:in setProperty' from java/lang/reflect/Method.java:498:ininvoke'
from C:/dev/elk/logstash-5.4.0/lib/pluginmanager/proxy_support.rb:40:in apply_env_proxy_settings' from C:/dev/elk/logstash-5.4.0/lib/pluginmanager/proxy_support.rb:62:inconfigure_proxy'
from C:\dev\elk\logstash-5.4.0\lib\pluginmanager\main.rb:26:in (root)' from C_3a_/dev/elk/logstash_minus_5_dot_4_dot_0/lib/pluginmanager/C:\dev\elk\logstash-5.4.0\lib\pluginmanager\main.rb:26:in(root)'

In order to dismiss issues wether what I did was incorrect I tried this at home on my own machine (using the same code) and it installed without any problem.

I get this error after defining http_proxy environment variable.

Any pointers/ideas?

Regards benny

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.