Logstash halted with error: Connection reset by peer

My logstash stopped over the weekend for some reason. I currently only have 1 beat. winlogbeat, shipping its logs to it, but if it breaks every time some1 restarts their PC or something, then thats obviously going to be an issue. I now dont have logs from the last 2 days. It worked friday, and then it looks like it broke saturday the 14th
What could be the problem here?

**EDIT

Maybe this is actually an Elasticsearch issue. Im getting this alot:


Which i think means something is wrong with my resource amounts. The VM has 64GB memory so that should be plenty. The jvm.options has -Xms16g and -Xmx16g.
What else is relevant here? There is something about shards and indices im not really understanding

I tried reading this https://www.elastic.co/blog/how-many-shards-should-i-have-in-my-elasticsearch-cluster, but i just dont really understand what im dealing with yet. I followed the "getting started" guide, and a couple of days later this happened. Not sure how many shards or indexes i have. There should not be a large amount of data. I have had 2 beats running for a couple of days on stale devices, so i cant imagine the space usage being the issue.