Logstash JDBC Plugin Cassandra, Maria Driver Not Working

I am Working on Logstash input Jdbc with different databases, Primarily I am trying for cassandra and I am using DBSchema driver, the driver is properly working with my java jdbc code, but when coming integrate with Logstash it was failing to connect, I am trying this from many days, i did n't find any exact solution in forum, i tried all the things, but not worked, with maria db was also i tried it is also failing.

Here I am providing Logs while starting Logstash
Error: com.dbschema.CassandraJdbcDriver not loaded. Are you sure you've included the correct jdbc driver in :jdbc_driver_library?
Exception: LogStash::ConfigurationError
Stack: /opt/logstash-7.1.1/vendor/bundle/jruby/2.5.0/gems/logstash-input-jdbc-4.3.13/lib/logstash/plugin_mixins/jdbc/jdbc.rb:163:in `open_jdbc_connection'

Logstash conf file: (Cassandra)
#Sample Logstash configuration for creating a simple
# Beats -> Logstash -> Elasticsearch pipeline.

input {
jdbc {
clean_run => true
jdbc_connection_string => "jdbc:cassandra://localhost:9042/cloud"
jdbc_user => "cassandra"
jdbc_password => "cassandra"
jdbc_driver_library => "/usr/share/logstash/logstash-core/lib/jars/cassandrajdbc1.2.jar"
jdbc_validate_connection => true
jdbc_driver_class => "com.dbschema.CassandraJdbcDriver"
statement => "SELECT * FROM cloud.event_history_all"

output {
elasticsearch { hosts => ["localhost:9200"]
index => "log_cassandra" }
stdout { codec => rubydebug }

Cassandra version -3.11.5
elk versions - 7.4.2
java version - 11.0.5

Thanks in advance

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.