Logstash JDBC SSL Error


I'm trying to use jdbc-input plugin to pull the data from oracle. It is working fine when using TCP connection string, but getting below error when trying to connect using TCP"S" connection (SSL).

[ERROR][logstash.inputs.jdbc ][main] Unable to connect to database. Tried 1 times {:error_message=>"Java::JavaSql::SQLRecoverableException: IO Error: Connection reset"}

I'm unable to find option to connect to oracle database using TCPS(SSL) connection. Please let me know if there is any such option available in other plugin.

Please let me know if anyone came across similar issue.

Still waiting for update..
It seems no one tried this option of using TCPS connection in oracle:jdbc as input to logstash.


Are you connecting to an HTTPS address where the certificate is signed by an internal issuer ? or a widely used/common public issuer ?

I'm connecting as common user. The source oracle database has listeners running on both TCP and TCPS. With TCP, my logstash is able to connect but its not working with TCPS.
With same user, when I'm trying sqlplus with both (TCP/TCPS) it is working.

It seems I might be missing some ssl enabled parameter in logstash. not sure though.

Can you post your config file... change out the password and url for dummy values first.

its probably something subtle

Below is my sample config file

input {
jdbc {
jdbc_validate_connection => true
jdbc_connection_string => "jdbc:oracle:thin:@:/"
jdbc_user => "user"
jdbc_password => "**"
jdbc_driver_class => "Java::oracle.jdbc.driver.OracleDriver"
statement_filepath => "dummy"
codec => plain {
charset => "UTF-8"
output {

I dont have oracle at hand at the moment to test before I post... but im wondering if its down to something simple like the format of the connection string and the error message not being helpful.

For example, if the database to which you want to connect resides on host prodHost , at port 1521 , and system identifier (SID) ORCL

jdbc_connection_string => "jdbc:oracle:thin:@prodHost:1521:ORCL"


Thank you for the update.

I had updated same in my sample config file.. somehow it didn't posted the complete message.
I'm using same connection string format which you have mentioned. It is working when I'm using TCP port/sid, and not working with TCPS port/sid.

The source oracle database is accepting connection on both (TCP and TCPS), but somehow logstash is unable to connect when using TCPS.

Still wondering if there is any such option in logstash.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.