Logstash monitoring on kibana


(Elastic-for-me) #1

I have following in config file but monitoring not getting display in kibana

xpack.monitoring.enabled: true
xpack.monitoring.elasticsearch.url: ["http://:9200", "https://:9200"]
xpack.monitoring.elasticsearch.sniffing: true
xpack.monitoring.collection.interval: 30s
xpack.management.enabled: false

I don't have any security setup yet.
kibana displays itself and elasticsearch cluster fine. what am I missing?


(Ry Biesemeyer) #2

What do your Logstash logs say when you start it up?

My best guess is that that they will be complaining about connecting to Elasticsearch for one of a couple possible reasons:

  • one of the URLs given include https scheme, but as you say, security has not yet been enabled on your Elasticsearch cluster.
  • the URLs given do not include a hostname; including a hostname (even one such as localhost) may help Logstash to find your Elasticsearch.

(Elastic-for-me) #3

I remove duplicate connection string and only kept http://hostname:9200. disable sniffing.

in log file only one error line is with error. everything thing else shows success

[2018-09-26T06:47:47,297][ERROR][logstash.inputs.metrics ] Failed to create monitoring event {:message=>"For path: events. Map keys: [:pipelines, :reloads]", :error=>"LogStash::Instrument::MetricStore::MetricNotFound"}

Kibana log says
{"type":"log","@timestamp":"2018-09-25T20:06:24Z","tags":["status","plugin:logstash@6.4.1","info"],"pid":530,"state":"green","message":"Status changed from yellow to green - Ready","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}
{"type":"log","@timestamp":"2018-09-26T11:59:12Z","tags":["status","plugin:logstash@6.4.1","info"],"pid":15262,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2018-09-26T11:59:14Z","tags":["status","plugin:logstash@6.4.1","info"],"pid":15262,"state":"green","message":"Status changed from yellow to green - Ready","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}


(Elastic-for-me) #4

this is fixed.
I didn't had any configuration file in conf.d dir. added sample config file and now I have monitoring showing up in kibana.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.