Logstash not fetching conf file during startup

OS : ubuntu 16.04
Logstash version : 6.4

I have recently installed logstash with apt package repository.

Every thing is as default, I have added /etc/logstash/conf.d/filebeat.conf where it should listen to port 5044 for incoming beat.

If logstash is started normally, it does not listen to port 5044. netstat -tulnp does not show the listening port. And I am confused to which port logstash is listening by default. log does not show any error as well.

But if i specify the conf file location, the intended port is listening and every thing works fine.

bin/logstash -f /etc/logstash/conf.d/filebeat.conf

Do i have to specify anything in logstash.yml or pipelines.yml or anywhere else? so that I do not have to specify the conf file.

What is your path.config: in logstash.yml ?

in logstash.yml


path.config: /etc/logstash/conf.d/filebeat.conf

Then run ./bin/logstash

I did as you said but the result gives me following error, some how it is unable to fetch logstash.yml and log4j2 files under /etc/logstash. I never had such issue with version 6.3. Do you think logstash 6.4 has some issue or different way of configuring?


WARNING: Could not find logstash.yml which is typically located in $LS_HOME/config or /etc/logstash. You can specify the path using --path.settings. Continuing using the defaults
Could not find log4j2 configuration at path /usr/share/logstash/config/log4j2.properties. Using default config which logs errors to the console
ERROR: Failed to read pipelines yaml file. Location: /usr/share/logstash/config/pipelines.yml
bin/logstash -f CONFIG_PATH [-t] [-r] [] [-w COUNT] [-l LOG]
bin/logstash -e CONFIG_STR [-t] [--log.level fatal|error|warn|info|debug|trace] [-w COUNT] [-l LOG]
bin/logstash -i SHELL [--log.level fatal|error|warn|info|debug|trace]
bin/logstash -V [--log.level fatal|error|warn|info|debug|trace]
bin/logstash --help
[ERROR] 2018-09-03 20:09:59.018 [LogStash::Runner] Logstash - java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

Finally, I have updated the file /etc/systemd/system/logstash.service to include


Restarted the services and everything is ready to go.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.