Logstash not processing data

Hi guys,

Trying to send data Logstash -> Elasticsearch (WIN 10, both are running on localhost, configs are tested and are ok) and I'm experiencing issue that actual data is not sent (this is the only warning I get):

[2019-08-05T07:42:58,444][WARN ][org.logstash.instrument.metrics.gauge.LazyDelegatingGauge] A gauge metric of an unknown type (org.jruby.specialized.RubyArrayOneObject) has been create for key: cluster_uuids. This may result in invalid serialization. It is recommended to log an issue to the responsible developer/development team.

Logstash Config:

input {
file {
	path => "C:/Miha/LogStash/logstash-7.2.0/logstash-7.2.0/bin/cars.csv"
	start_position => "beginning"
	sincedb_path => "/dev/null"
}

}
filter {
csv {
separator => ","

	columns => [ "maker", "model", "mileage", "manufacture_year", "engine_displacement", 
	"engine_power", "body_type", "color_slug", "stk_year", "transmission", "door_count", 
	"seat_count", "fuel_type", "date_created", "date_last_seen", "price_eur" ]
}

mutate {convert => ["mileage", "integer"]}
mutate {convert => ["price_eur", "float"]}
mutate {convert => ["engine_power", "integer"]}
mutate {convert => ["door_count", "integer"]}
mutate {convert => ["seat_count", "integer"]}

}

output {
elasticsearch {
hosts => ["http://localhost:9200"]
index => "cars"
document_type => "sold_cars"
}
stdout {}
}

Many thanks in advance!

Try inserting the following 2 lines after your since_db one:
close_older => "1 hour"
stat_interval => "1 second"

Thx, tried and unfortunately without success.

I'm trying to send data between two logs and also is not working:

Config:

input {

file {
path => "C:/Miha/LogStash/logstash-7.2.0/logstash-7.2.0/data/logs/logs222.log"
}
}

output {
file {
path => "C:/Miha/LogStash/logstash-7.2.0/logstash-7.2.0/data/logs/logs33.log"
}
}

Any ideas?

from the output section remove "document_type" directive and try.
Don't worry about the warning.

On Windows that should be

sincedb_path => "NUL"
1 Like

Many thanks Badger. It works now!