Logstash not reading .conf-file when running as a service

My apologies if this issue already has been answerd, although I've done some searching and haven't found any other thread with the problem I am experiencing. Similar ones, but not really what I'm looking for ...

So, here it goes:
I installed the entire ELK-stack using the rpm:s provided. After that everything started up nicely and everything almost works. I.e. part from Logstash seemingly not reading the .conf-file in /etc/logstash/conf.d/ directory.

Tried starting it from the command line and indicating the logstash.conf file in the same directory (-f) and everything works as expected, no problem. Except; Logstash not running as a service ...

So, my question(s):

  • How do I indicate in the service script(s) that there is a .conf-file to be honored?
  • Could it be permissions missing? (chmod:ed to temporarily allow anything for the .conf-file, to no avail)
  • The logstash.yml has not been touched so it is the default one from the installation. Do I need to make some amendments to it for this?

The OS I am currenetly working on: Red Hat Enterprise Linux Server release 7.4 (Maipo)
Logstash version: 6.0.0
Command for starting Logstash as a service: systemctl start logstash.service

Thank you in advance for any pointers for solving this, probably, smallish issue.

Edit: recently found another issue indicating changing owner of directory and .conf-file. Tried it also, but to no avail.

It has been a while now and no replies as yet. Tried some various actions getting Logstash to read my .conf-file located in the directory /etc/logstash/conf.d ... but none seems to work.
Logsatsh-team: have I missed something crucial? If so, could you please send a pointer to the docs or whatever I should read up on.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.