Logstash not sending logs to custom elasticsearch index


(ishtikhar khan) #1

Here is my filebeat.yml configuration file
#=========================== Filebeat inputs =============================

filebeat.inputs:

Each - is an input. Most options can be set at the input level, so

you can use different inputs for various configurations.

Below are the input specific configurations.

  • type: log

    Change to true to enable this input configuration.

    enabled: true

    Paths that should be crawled and fetched. Glob based paths.

    paths:
    #- /var/log/*.log

    • /var/log/messages
    • /var/log/cron

and my logstash configuration file
input {

beats {
port => 5044
}

}

output {
elasticsearch {

  hosts => ["192.168.122.68:9200"]
  index => "message_logs"

}
}
~


(ishtikhar khan) #2

pls. help


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.