Logstash not using bundled JDK

Hey Elastic team,
im using logstash 7.11.0 and ubuntu 14.04
Whenever i run it manually like this

sudo /usr/share/logstash/bin/logstash --path.settings /etc/logstash

logstash running as expected and using bundled JDK, but when i try to run the same command using supervisor service it fails with error message Using JAVA_HOME defined java: /usr/lib/jvm/default-java

The supervisor service file looks like this:

command                 = /usr/share/logstash/bin/logstash --path.settings /etc/logstash
process_name            = %(program_name)s
directory               = /etc/logstash
autostart               = true
autorestart             = true
user                    = root
stdout_logfile_maxbytes = 1MB
stdout_logfile_backups  = 0
stderr_logfile_maxbytes = 1MB
stderr_logfile_backups  = 0

What can cause this kind of behaviour and how can i overcome it?
Is there any other way to make logstash use bundled JDK and keep JAVA_HOME set?

Thanks in advance

You tell logstash to use an unbundled JDK by setting JAVA_HOME. If, for some reasons, you want to have JAVA_HOME set and use the bundled JDK you would have to locate the bundled JDK and point JAVA_HOME at it.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.