Logstash not working until I re-save the file

The logstash is not parsing the csv logs files automatically. It works only after I reopen the file and save it again.
Sometimes, if the log files are more than 1GB, opening the files with Excel ( or any other editor) is either giving issues, or saving it causing the files to be truncated to the maximum file size supported by Excel ( or other tools ).

Software details
Logstash 2.2.2
Windows 7
Microsoft Excel for viewing the CSV data

Have a look here: Problem input file version 2.2.0.
The ignore_older option is added to Logstash 2.2.2.


If you are using a static file for debugging purpose,
you can try to add
sincedb_path = "/dev/null"
in your file input.

1 Like

Thanks @DaanCreemers .. that solves the issue .

1 Like