Logstash output plugin elastic_app_search not found

I've been scratching my head for the last couple of hours on this but I can't seem to figure out why Logstash can't find the elastic_app_search output plugin. I have a tar.gz install of Logstash 7.9.1 (running on a Mac) and installed the plugin via the bin/logstash-plugin install command and see it listed:

logstash-output-csv
logstash-output-elastic_app_search
logstash-output-elasticsearch
logstash-output-email

But when I run Logstash, I get this error:

[2020-09-15T00:05:56,773][ERROR][logstash.plugins.registry] Tried to load a plugin's code, but failed. {:exception=>#<LoadError: no such file to load -- elastic-app-search>, :path=>"logstash/outputs/elastic_app_search", :type=>"output", :name=>"elastic_app_search"}

Any idea what might be going on? Could something be going strange with the naming (underscores vs. dashes)? Thanks in advance for any help!

Fixed by engineering team: https://github.com/logstash-plugins/logstash-output-elastic_app_search/issues/17. Thanks!