Logstash package dependancy

Hi all.

Just trying to use logstash puppet class from Puppetlabs.
Have got some problem with installing package from direct
download https://download.elasticsearch.org/logstash/logstash/packages/centos/logstash-1.4.2-1_2c0f5a1.noarch.rpm

RPM says

Error: Could not update: Execution of '/bin/rpm -i
/var/lib/logstash/swdl/logstash-1.4.2-1_2c0f5a1.noarch.rpm' returned 1:
error: Failed dependencies:
jre >= 1.6.0 is needed by logstash-1.4.2-1_2c0f5a1.noarch

But i have 1.7.0 java sdk already installed

yum info java-1.7.0-openjdk
Installed Packages
Name : java-1.7.0-openjdk
Arch : x86_64
Epoch : 1
Version :
Release :
Size : 53 M
Repo : installed
Summary : OpenJDK Runtime Environment
URL : http://openjdk.java.net/
License : ASL 1.1 and ASL 2.0 and GPL+ and GPLv2 and GPLv2 with
exceptions and LGPL+ and LGPLv2 and MPLv1.0 and MPLv1.1 and Public Domain
and W3C
Description: The OpenJDK runtime environment.

And when I installed java-1.6.0-openjdk
everything went ok

Any thoughts?

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9885b050-051a-4c46-953a-5f6d087281f9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.