Logstash Permission denied - NUL error

Hello I am new to EleasticSearch.
I try to run logstash on Windows for the first time with different instrutions/Java versions/Logtash versions but always get the same error. I checked out the forms too but could not find a solution. A help will be appreciated.

Logstash - Logstash stopped processing because of an error: (EACCES) Permission denied - NUL
org.jruby.exceptions.SystemCallError: (EACCES) Permission denied - NUL
at org.jruby.RubyIO.sysopen(org/jruby/RubyIO.java:1237) ~[jruby.jar:?]
at org.jruby.RubyFile.initialize(org/jruby/RubyFile.java:365) ~[jruby.jar:?]
at org.jruby.RubyIO.open(org/jruby/RubyIO.java:1156) ~[jruby.jar:?]

Welcome to our community! :smiley:

it'd be useful if you showed us your Logstash config.

Hi @Ersan,

This is a known issue with the latest version of the JDK on Windows. Can you try adding


to your LOGSTASH_HOME\config\jvm.options file and restart?

1 Like

Thank you very much Bob. It solved my problem.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.