Logstash Pipeline with elasticsearch output missing in Stack Monitoring

Hi!

We are currently setting up monitoring for our Logstash instances.
Metricbeat on the Logstash is configured as described in the instructions:

- module: logstash
  metricsets:
    - node
    - node_stats
  xpack.enabled: true
  period: 10s
  hosts: ["localhost:9600"]
output.elasticsearch:
  # Array of hosts to connect to.
  hosts:
    - https://es-rm-1.<domain>
    - https://es-rm-2.<domain>

  # Protocol - either `http` (default) or `https`.
  #protocol: "https"

  username: "logstash"
  password: "redacted"

Receiving data works fine, the stack monitoring shows informations about pipelines.
These pipelines exist: syslog, exim, dhcpd, radiusd, panorama, output-elastic, output-percent

However, for some reason, specifically pipelines with an output plugin "elasticsearch" are not shown:

As soon as I replace the elasticsearch output plugin with the stdout plugin, the pipeline shows up in the view. Is this by design or is there a setting we have to change?

FWIW, the pipeline does show up in the output of http://localhost:9600/_node/stats/pipelines

curl -s http://localhost:9600/_node/stats/pipelines | jq -r '.pipelines | to_entries[] | .key'
output-percent
exim
radiusd
dhcpd
panorama
output-elastic
syslog

Thanks for any help!
Best Regards
Peter

We got this fixed by accident.
Previously, we only had Metricbeat installed on the Logstash systems. After we installed Metricbeat on all Elasticsearch nodes, the pipelines appeared in the Logstash stack monitoring. It seems that some necessary data was missing before we installed Metricbeat everywhere.