Logstash plugin install network error


#1

Hey, cant seem to install/update the beats plugin, keeps giving network error. I do have internet connection.

./bin/logstash-plugin update logstash-input-beats
Updating logstash-input-beats
Error Bundler::HTTPError, retrying 1/10
Network error while fetching https://rubygems.org/quick/Marshal.4.8/logstash-devutils-1.1.0-java.gemspec.rz
Error Bundler::HTTPError, retrying 2/10
Network error while fetching https://rubygems.org/quick/Marshal.4.8/logstash-devutils-1.1.0-java.gemspec.rz
Error Bundler::HTTPError, retrying 3/10
Network error while fetching https://rubygems.org/quick/Marshal.4.8/logstash-devutils-1.1.0-java.gemspec.rz
Error Bundler::HTTPError, retrying 4/10
Network error while fetching https://rubygems.org/quick/Marshal.4.8/logstash-devutils-1.1.0-java.gemspec.rz

#2

not sure what i did but now it s like this:

# ./bin/logstash-plugin install logstash-input-beats
Validating logstash-input-beats
Installing logstash-input-beats
Error Bundler::InstallError, retrying 1/10
An error occurred while installing logstash-core-event-java (5.0.1), and Bundler cannot continue.
Make sure that `gem install logstash-core-event-java -v '5.0.1'` succeeds before bundling.

(Magnus B├Ąck) #3

Do you have a firewall or proxy that blocks direct access to rubygems.org?


#4

Yeah probably i had, dont remember how i fixed it but it s working now :slight_smile:


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.