Logstash port 5044 is not listening after logstash Installation

Dear all,
I would like to receive log from remote server through file beat .However I find the port 5044 is not listening but status of logstash is active and enable. I did all the configuration needed for logstash.any idea?

This is Logstash service status

Hi @Nilesh1997 Welcome to the community!.

First, please don't paste pictures of text. They cannot be read by many cannot be searched and cannot be debugged.

You provided very little information so here are a few questions, The more details you provide, the easier it is for us to help.

How do you know logstash not listening on 5044? Did you try to telnet to it?

Did you use journalctl to look at the logs? There will be a line that will show if the beats listener and port is opened or not or if there's an issue.

journalctl --unit logstash

Third, you didn't provide any of your configurations so if you have an error then we can't see. .

Check /var/log/logstash/logstash.log, if you need enable debug mode in /etc/logstash/logstash.yml