Logstash service will not run (Ubuntu server 14.04)


I'm trying out the ELK stack on an environment of 1 ELK server, two client servers and one laptop to access Kabina.

I have followed https://www.digitalocean.com/community/tutorials/how-to-install-elasticsearch-logstash-and-kibana-elk-stack-on-ubuntu-14-04 throughout and got to the point where I am configuring my client servers.

I came across a problem. I set up filebeat and configured it by following the guide, everything worked out well but when I try to restart the filebeat service to save the changes I get the following message:

  • Restarting Sends log files to Logstash or directly to Elasticsearch. filebeat 2016/03/17 14:25:12.419905 transport.go:125: ERR SSL client failed to connect with: dial tcp XXX.XXX.XXX.XXX:5044: getsockopt: connection refused.

I tried to troubleshoot this myself and thought that something was wrong with either the SSL cert I made or the port. But I'm pretty sure my configs are correct.

After some time I noticed that my logstash service was not running so i went ahead and started it, but and it started up but after 5 seconds it just goes back to not running.

Can someone help me out?

Check your LS logs, if there is nothing run LS directly using the same command as the service to see what is happening.

Created a new topic with much more info, this one can be closed