Logstash shutdown with no error

I got following messages after starting Logstash

Jun 09 10:48:10 local systemd[1]: Started logstash.
Jun 09 10:48:10 local logstash[3191]: Using bundled JDK: /usr/share/logstash/jdk
Jun 09 10:48:11 local logstash[3191]: OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Jun 09 10:48:35 local logstash[3191]: Sending Logstash logs to /usr/share/logstash/logs which is now configured via log4j2.properties
Jun 09 10:48:35 local logstash[3191]: [2022-06-09T10:48:35,126][INFO ][logstash.runner          ] Log4j configuration path used is: /etc/logstash/log4j2.properties
Jun 09 10:48:35 local logstash[3191]: [2022-06-09T10:48:35,146][INFO ][logstash.runner          ] Starting Logstash {"logstash.version"=>"8.2.2", "jruby.version"=>"jruby 9.2.20.1 (2.5.8) 2021-11-30 2a2962fbd1 OpenJDK 64-Bit Server VM 11.0.14.1+1 on 11.0.14.1+1 +indy +jit [linux-x86_64]"}
Jun 09 10:48:35 local logstash[3191]: [2022-06-09T10:48:35,149][INFO ][logstash.runner          ] JVM bootstrap flags: [-Xms1g, -Xmx1g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djruby.compile.invokedynamic=true, -Djruby.jit.threshold=0, -XX:+HeapDumpOnOutOfMemoryError, -Djava.security.egd=file:/dev/urandom, -Dlog4j2.isThreadContextMapInheritable=true, -Djruby.regexp.interruptible=true, -Djdk.io.File.enableADS=true, --add-opens=java.base/java.security=ALL-UNNAMED, --add-opens=java.base/java.io=ALL-UNNAMED, --add-opens=java.base/java.nio.channels=ALL-UNNAMED, --add-opens=java.base/sun.nio.ch=ALL-UNNAMED, --add-opens=java.management/sun.management=ALL-UNNAMED]
Jun 09 10:48:38 local logstash[3191]: [2022-06-09T10:48:38,013][INFO ][logstash.agent           ] Successfully started Logstash API endpoint {:port=>9600, :ssl_enabled=>false}
Jun 09 10:48:38 local logstash[3191]: [2022-06-09T10:48:38,877][INFO ][org.reflections.Reflections] Reflections took 120 ms to scan 1 urls, producing 120 keys and 395 values
Jun 09 10:48:39 local logstash[3191]: [2022-06-09T10:48:39,338][INFO ][logstash.javapipeline    ] Pipeline `main` is configured with `pipeline.ecs_compatibility: v8` setting. All plugins in this pipeline will default to `ecs_compatibility => v8` unless explicitly configured otherwise.
Jun 09 10:48:39 local logstash[3191]: [2022-06-09T10:48:39,427][INFO ][logstash.outputs.elasticsearch][main] New Elasticsearch output {:class=>"LogStash::Outputs::ElasticSearch", :hosts=>["//localhost:9200"]}
Jun 09 10:48:39 local logstash[3191]: [2022-06-09T10:48:39,941][INFO ][logstash.outputs.elasticsearch][main] Elasticsearch pool URLs updated {:changes=>{:removed=>[], :added=>[http://localhost:9200/]}}
Jun 09 10:48:40 local logstash[3191]: [2022-06-09T10:48:40,189][WARN ][logstash.outputs.elasticsearch][main] Restored connection to ES instance {:url=>"http://localhost:9200/"}
Jun 09 10:48:40 local logstash[3191]: [2022-06-09T10:48:40,203][INFO ][logstash.outputs.elasticsearch][main] Elasticsearch version determined (8.2.2) {:es_version=>8}
Jun 09 10:48:40 local logstash[3191]: [2022-06-09T10:48:40,205][WARN ][logstash.outputs.elasticsearch][main] Detected a 6.x and above cluster: the `type` event field won't be used to determine the document _type {:es_version=>8}
Jun 09 10:48:40 local logstash[3191]: [2022-06-09T10:48:40,276][INFO ][logstash.outputs.elasticsearch][main] Config is compliant with data streams. `data_stream => auto` resolved to `true`
Jun 09 10:48:40 local logstash[3191]: [2022-06-09T10:48:40,283][INFO ][logstash.outputs.elasticsearch][main] Config is compliant with data streams. `data_stream => auto` resolved to `true`
Jun 09 10:48:40 local logstash[3191]: [2022-06-09T10:48:40,295][WARN ][logstash.outputs.elasticsearch][main] Elasticsearch Output configured with `ecs_compatibility => v8`, which resolved to an UNRELEASED preview of version 8.0.0 of the Elastic Common Schema. Once ECS v8 and an updated release of this plugin are publicly available, you will need to update this plugin to resolve this warning.
Jun 09 10:48:40 local logstash[3191]: [2022-06-09T10:48:40,409][INFO ][logstash.javapipeline    ][main] Starting pipeline {:pipeline_id=>"main", "pipeline.workers"=>2, "pipeline.batch.size"=>125, "pipeline.batch.delay"=>5, "pipeline.max_inflight"=>250, "pipeline.sources"=>["/etc/logstash/conf.d/simple.conf"], :thread=>"#<Thread:0x2e8c2bdb run>"}
Jun 09 10:48:40 local logstash[3191]: [2022-06-09T10:48:40,448][INFO ][logstash.outputs.elasticsearch][main] Using a default mapping template {:es_version=>8, :ecs_compatibility=>:v8}
Jun 09 10:48:41 local logstash[3191]: [2022-06-09T10:48:41,366][INFO ][logstash.javapipeline    ][main] Pipeline Java execution initialization time {"seconds"=>0.95}
Jun 09 10:48:42 local logstash[3191]: [2022-06-09T10:48:42,106][INFO ][logstash.javapipeline    ][main] Pipeline started {"pipeline.id"=>"main"}
Jun 09 10:48:42 local logstash[3191]: [2022-06-09T10:48:42,253][INFO ][logstash.agent           ] Pipelines running {:count=>1, :running_pipelines=>[:main], :non_running_pipelines=>[]}
Jun 09 10:48:43 local logstash[3191]: [2022-06-09T10:48:43,342][INFO ][logstash.javapipeline    ][main] Pipeline terminated {"pipeline.id"=>"main"}
Jun 09 10:48:43 local logstash[3191]: [2022-06-09T10:48:43,856][INFO ][logstash.pipelinesregistry] Removed pipeline from registry successfully {:pipeline_id=>:main}
Jun 09 10:48:44 local logstash[3191]: [2022-06-09T10:48:44,007][INFO ][logstash.runner          ] Logstash shut down.
Jun 09 10:48:44 local systemd[1]: logstash.service holdoff time over, scheduling restart.
Jun 09 10:48:44 local systemd[1]: Stopped logstash.

=======================

/etc/logstash/conf.d/simple.conf :

input { stdin {} }
output {
  elasticsearch { hosts => ["localhost:9200"] }
}

=======================
/etc/logstash/logstash.yml :

   pipeline:
     batch:
       size: 125
       delay: 5
   pipeline.batch.size: 125
   pipeline.batch.delay: 5

 log.level: debug
path.logs: /var/log/logstash

If you start logstash as a service then a stdin input will immediately encounter EOF on standard input (since it is linked to /dev/null). That will cause logstash to shutdown, since it has no further work to do.

1 Like

I removed and it worked. thanks.