Logstash Startup 401 error on Windows 10

I'm installing ELK on my windows 10 workstation and I've gone through the steps to install all three; although there was a few issues with authorization during the process, Elasticsearch and Kibana are working perfectly fine. I just moved onto Logstash, I have everything installed and I've created a .conf file that should allow me to create messages from terminal but I'm getting a 401 error code whenever I try to run the .bat file alongside my .conf file. The entire process is attached below.

I understand that it's having a problem connecting to Elasticsearch but I've tried everything I could with trying different configurations for the .yml files. I've also tried to change the password to the logstash-user as that seemed to fix my issue with kibana but it doesn't allow me to change the password this time (picture attached).

Any help would be appreciated, as I'm not sure what I've missed.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.