Logstash Successfully started but not index in created in Elastic Search


(Venkatraman Muthukrishnan) #1

Hi-All,

I am a newbie to logstash, When I tried to dump a csv file data by creating a index through logstash The console output says

"[2018-10-07T16:00:42,081][INFO ][logstash.agent ] Successfully started Logstash API endpoint {:port=>9601}"
but index is not created in ES. I don't know where might be the problem.

When i started in --debug mode it loops in below line:

[2018-10-07T16:00:46,761][DEBUG][logstash.pipeline ] Pushing flush onto pipeline {:pipeline_id=>"main", :thread=>"#<Thread:0x526bc1e2 sleep>"}

[2018-10-07T16:00:50,532][DEBUG][logstash.instrument.periodicpoller.cgroup] One or more required cgroup files or directories not found: /proc/self/cgroup, /sys/fs/cgroup/cpuacct, /sys/fs/cgroup/cpu

[2018-10-07T16:00:50,552][DEBUG][logstash.instrument.periodicpoller.jvm] collector name {:name=>"ParNew"}

Refer my attached logstash.conf and log file

https://goo.gl/5hdepG
Anyone help me!!!!


#2

Hi,
Refer to this link for windows,


(Rakesh) #3

@balumurari1 I tried with the suggested input in conf file but getting the same error as venkatraman_Muthukri.

Thanks,
Rakesh


#4

Hi Rakesh,

If you could provide the input code, then it is easy to identify the error.

Regards,
Balu


(Venkatraman Muthukrishnan) #5

I use Mac machine for stashing


(Maria kavya Thirumalareddy) #6

Hi All,

I have installed elk stack in windows 2012 R2 server ad see the same issue. Can some help me in resolving it?


(Leonardo Cavalcante) #7

I'm having the same problem with the cgroup not found.

[2018-10-12T17:04:46,096][DEBUG][logstash.config.source.local.configpathloader] Reading config file {:config_file=>"E:/Documentos/Faculdade/TCC/data/logstash_mapas.config"}
[2018-10-12T17:04:46,252][DEBUG][logstash.agent ] Converging pipelines state {:actions_count=>1}
[2018-10-12T17:04:46,282][DEBUG][logstash.agent ] Executing action {:action=>LogStash::PipelineAction::Create/pipeline_id:main}
[2018-10-12T17:04:50,278][DEBUG][logstash.instrument.periodicpoller.cgroup] One or more required cgroup files or directories not found: /proc/self/cgroup, /sys/fs/cgroup/cpuacct, /sys/fs/cgroup/cpu
[2018-10-12T17:04:50,927][DEBUG][logstash.instrument.periodicpoller.jvm] collector name {:name=>"ParNew"}
[2018-10-12T17:04:50,944][DEBUG][logstash.instrument.periodicpoller.jvm] collector name {:name=>"ConcurrentMarkSweep"}
[2018-10-12T17:04:53,698][DEBUG][logstash.plugins.registry] On demand adding plugin to the registry {:name=>"file", :type=>"input", :class=>LogStash::Inputs::File}
[2018-10-12T17:04:54,264][DEBUG][logstash.plugins.registry] On demand adding plugin to the registry {:name=>"plain", :type=>"codec", :class=>LogStash::Codecs::Plain}

The logstash.config file:

input {
	file {
	 	path => "E:/Documentos\Faculdade\TCC\data\mapas.csv"
	 	start_position => "beginning"
	 	sincedb_path => "E:/Documentos\Faculdade\TCC\data\null"
	}
}
filter {
	csv {
		separator => ","

		columns => [ "cod_mapa_planta", "reg_adm", "org_set_origem", "num_mapoteca", "gaveta_mapoteca", "prancha_mapoteca", "titulo_mapa_planta", "endereco_mapa_planta_antigo", "bairro_mapa_planta_antigo", "municipio_uf_antigo", "cep_mapa_planta_antigo", "endereco_mapa_planta_novo", "bairro_mapa_planta_novo", "municipio_uf_novo", "cep_mapa_planta_novo", "tipologia_mapa_planta", "trecho_tipologia", "municipio_tipologia", "num_processo_tipologia", "supervisor_origem_tipologia", "org_emissor_origem_tipologia", "dimensao_imovel_area_total_tipologia", "confrontamento_tipologia", "autor_tipologia", "original_copia_tipologia", "data_tipologia", "escala", "num_folha", "descritores", "planta",  "armario", "tela", "tubo", "quant", "observacao", "data_cadastramento", "cadastrador", "sel", "latitude", "longitude" ]
	}

	mutate {convert => ["cod_mapa_planta", "integer"]}
	mutate {convert => ["num_mapoteca", "integer"]}
	mutate {convert => ["gaveta_mapoteca", "integer"]}
	mutate {convert => ["quant", "integer"]}
	mutate {convert => ["latitude", "float"]}
	mutate {convert => ["longitude", "float"]}

}
output {
	elasticsearch {
		hosts => "localhost"
		index => "mapas"
		document_type => "mapas_registrados"
	}
	stdout{}
}

I'm with logstash-6.4.2 and Win 10.


#8

Hello,
As observed from your input code, cahnge the path as shown below

path => "E:/Documentos/Faculdade/TCC/data/mapas.csv"

since db path to

sincedb_path => "NUL",

hope this works


(Leonardo Cavalcante) #9

That worked! Thank you very much!


(system) #10

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.