Logstash-tcp-input not parsing proxy protocol header


(Brendan Johnson) #1

I have an NGINX loadbalancer configured to use proxy protocol when sending to logstash instances on the backend. Here is my input config

input {
tcp {
port => 5002
proxy_protocol => true
type => "cisco-asa"
}
}

this is what shows up in the proxy_host and proxy_port field.

image

I can't figure out what I am doing wrong. There doesn't appear to be additional configuration option beyond setting proxy_protocol => true.


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.