Logstash v6 beta with multiple pipelines configuration


#1

Hello,

Thanks for reading this. I am trying out Logstash v6 and multiple pipeline configuration, as per https://www.elastic.co/guide/en/logstash/6.x/multiple-pipelines.html

I have configured my pipelines.yml follows:

  • pipeline.id: influxdb-remote
    path.config: "/etc/logstash/conf.d/logstash-influx-data.conf"
    pipeline.workers: 2

  • pipeline.id: elasticsearch-remote
    path.config: "/etc/logstash/conf.d/logstash-test1.conf"
    pipeline.workers: 2

When I run logstash, without any option, I get the following message:
sudo /usr/share/logstash/bin/logstash
[WARN ][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified
[INFO ][logstash.agent ] Successfully started Logstash API endpoint {:port=>9600}
.........
[INFO ][logstash.pipeline ] Pipeline started {"pipeline.id"=>"main"}
[INFO ][logstash.agent ] Pipelines running {:count=>1, :pipelines=>["main"]}

How to run multiple pipelines, so logstash doesnt ignore my pipelines.yml? I have no command line options or modules specified....
How to verify how many pipelines I have running?


Pipelines.yml ignored on logstash running as a service
#2

Note, in above output there was only one pipeline started for two config files which are located in /etc/logstash/conf.d/ dir.
pipelines.yml seems to have been ignored.


#3

It seems that path.config in Logstash in rpm needs to be commented out as per information on GitHub:

Logstash will then use pipeline.yml.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.