Elastic 6.4.1 on CentOS 7 x64 - Pipelines.yml Question


(Eloy Sanchez) #1

Hello,

Our installation is progressing and I'm setting up logstash. I've got it to run with the noted test config file here: https://www.elastic.co/guide/en/logstash/current/configuration.html However, I am receiving a message after running the "sudo bin/logstash -f logstash-simple.conf --path.settings /etc/logstash" command:

[WARN] [logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because module or command line options are specified

Do I need to do anything to correct this? Further down in the messages, I have these messages:

[logstash.pipeline] Pipeline started successfully {pipeline_id=>"main", :thread=>"#<Thread:0x588a6b7a run>"} The stdin plugin is now waiting for input:
[logstash.agent] Pipelines running {:count=>1, :running_pipelines=>[:main], :non_running_pipelines=>[]}

I have not defined any pipelines in my etc/logstash/pipelines.yml file yet.

Thank you,

Eloy Sanchez


(Andreas H) #2

You can ignore the warning as you are using the -f parameter when running logstash.
You have defined a main pipeline (default name when one isn't explicitly defined) because you used the -f parameter which only uses one config file.


(Eloy Sanchez) #3

Andreas,

Thank you for the reply and explanation of what the -f parameter does while using this test case as my config file.

Eloy


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.