Logstash.yml Elastic Cloud Settings


(Tim Schoffelman) #1

In my Logstash.yml file, I've added both my cloud.id and cloud.auth information (both with and without quotes for the value). In each case, when running my conf it tries to connect to my 127.0.0.1 localhost. I was able to finally connect by setting the output section in my conf file to the below example.

But what I wonder, is there anything I'm missing with my logstash.yml file? Shouldn't that connect to my cloud instance without having to add the below settings to my output {} section of my conf file? I'm running bin/logstash -f config/config-file.conf from the command line.

hosts => ["SUB_DOMAIN.us-west-2.aws.found.io:9243"]
user => NAME
password => PASSWORD
ssl => true

(Tim Schoffelman) #2

I should add both Elastsearch in the cloud and Logstash on my local machine are versions 6.4.2. With the command line, when using the logstash.yml file, i've ran the following command:

bin/logstash --modules netflow -M "netflow.var.input.udp.port=3555"


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.