Logstash


(sylvain) #1

hello
I set new versions : elasticsearch kibana and logstach
i have these errors with my config file txt who was ok with previous versions:

l\logstash_titulaires_config_file.txt
io/console not supported; tty will not be manipulated
←[31mUnknown setting 'protocol' for elasticsearch {:level=>:error}←[0m
←[31mUnknown setting 'cluster' for elasticsearch {:level=>:error}←[0m
←[31mUnknown setting 'bind_host' for elasticsearch {:level=>:error}←[0m
Error: Something is wrong with your configuration.
You may be interested in the '--configtest' flag which you can
use to validate logstash's configuration before you choose
to restart a running system.


Elasticsearch logstach
(Mark Walkom) #2

Providing your config will help.

Also please use a more descriptive title.


(Aaron Mildenstein) #3

In Logstash 2.0, the Elasticsearch output uses the http protocol by default, and no longer contains the node or transport protocols. These errors clearly indicate you were using either the node or transport protocol to connect to Elasticsearch. This is not recommended with Elasticsearch 2.0. I do recommend switching to connect via HTTP. If you have a clear path to port 9200 on the target machine, this should happen automatically if you remove the protocol, cluster, and bind_host options.

If you insist on using either the node or transport protocol in spite of the official recommendations from both Elasticsearch and Logstash, you must install the logstash-output-elasticsearch_java plugin and change your output block to be elasticsearch_java {} instead of elasticsearch {}. Install this plugin by running bin/plugin install logstash-output-elasticsearch_java from your Logstash directory. This method requires internet access.


(sylvain) #4

Hello,

yes you were right,
problems were from there, i removed protocol, cluster modified host
that's ok

thanks


(system) #5