Loss of indexes after masters were damaged


(Andreas) #1

Hi,

actually we are running a cluster of 3 master nodes and 6 data nodes. Everything is amazon aws based. By accident we lost our masters completely. After creating three new master nodes they connected to the cluster but the indexes are not visible. The volumes are still available and the indexes are on the volumes. But when you lookup the cluster, they are not visible and you cannot query the indexes.

{"cluster_name":"ascribeelastic",curl localhost:9200/_cluster/health/
{"cluster_name":"ascribeelastic","status":"green","timed_out":false,"number_of_nodes":9,"number_of_data_nodes":6,"active_primary_shards":0,"active_shards":0,"relocating_shards":0,"initializing_shards":0,"unassigned_shards":0,"number_of_pending_tasks":0}
$

$ curl 'localhost:9200/_cluster/health?level=indices&pretty'
{
"cluster_name" : "ascribeelastic",
"status" : "green",
"timed_out" : false,
"number_of_nodes" : 9,
"number_of_data_nodes" : 6,
"active_primary_shards" : 0,
"active_shards" : 0,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 0,
"number_of_pending_tasks" : 0,
"indices" : { }
}

$ curl localhost:9200/_cat/shards
$

Anyone who can help?

Thanks,
Andreas


(Mark Walkom) #2

What version are you on?
Dangling indices should pick these up by default, have you tried restarting the data nodes?


(Andreas) #3

The version is 1.52, and yes, I restarted the whole cluster. Result: status is green an no indicies...totally empty.
Just in case In forced the import with gateway.local.auto_import_dangled (which is bei default enabled): same result. Cluster is totally empty, condition is green.


(system) #4