Low level java client not putting messages to elastic search


I am using this version of elastic client.


I wrote standalone java app with password auth and it worked fine to put messages to ES.

I used same code but with ouath token, I am not getting any error while sending message but that message is not visible anywhere. I am not getting where its lost.
Using performRequestAsync method in both cases.
Only difference is When I use oauth, app runs under tomcat container.
When I copied token and ran code locally, it gave me 201 - response but again, clueless on where is my doc.

What version of Elasticsearch are you using? How is the cluster configured?

I believe oauth requires a commercial or trial license, so what is the output of the get license API?


I am using 7.17.3 and yes, its licensed and my other apps are successufully doing bulk request using high level client+oauth.
Using Ouath + standalone app also worked for me in async mode but not working(no error /no callback call) when doing via tomcat webapp.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.