Make clients not listen on network ports


(Jordan Sissel) #1

Howdy!

So I have an elasticsearch client started roughly like this:

org.elasticsearch.node.NodeBuilder.nodeBuilder.client(true).node

I'm seeing these 'client' elasticsearch nodes set up the http and thrift(?)
listeners. Is there an easy way to disable this?

-Jordan


(Shay Banon) #2

Thrift is started (I guess) because you have the thrift plugin installed. Http start automatically. This is mainly because client nodes can actually act as proxies.

In order to disable it, set http.enabled to false, and thrift.enabled to false.

-shay.banon
On Monday, May 9, 2011 at 3:35 AM, Jordan Sissel wrote:

Howdy!

So I have an elasticsearch client started roughly like this:

org.elasticsearch.node.NodeBuilder.nodeBuilder.client(true).node

I'm seeing these 'client' elasticsearch nodes set up the http and thrift(?) listeners. Is there an easy way to disable this?

-Jordan


(system) #3