Mapped_geo_shape test error but I don't use any geo code v7.16.3

I have a class that extends AbstractQueryTestCase and all of its tests are failing, included ones that I didn't override, with the same stacktrace error:

Failed to parse mapping [_doc]: No handler for type [geo_shape] declared on field [mapped_geo_shape]
MapperParsingException[Failed to parse mapping [_doc]: No handler for type [geo_shape] declared on field [mapped_geo_shape]]; nested: MapperParsingException[No handler for type [geo_shape] declared on field [mapped_geo_shape]];
at app//org.elasticsearch.index.mapper.MapperService.parseMappings(
at app//org.elasticsearch.index.mapper.MapperService.mergeAndApplyMappings(
at app//org.elasticsearch.index.mapper.MapperService.merge(
at app//org.elasticsearch.test.AbstractBuilderTestCase$ServiceHolder.<init>(
at app//org.elasticsearch.test.AbstractBuilderTestCase.lambda$beforeTest$0(

Searching this forum for mapped_geo_shape reveals other users have solved this error by including a couple dependencies but I have tried that a few different ways without luck. See my attempst commented out in my build.gradle file

Any advice on how to properly include jts-core and spatial4j dependencies or is something else wrong?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.