Mapper Attachment: content not decoded

I followed the steps in this tutorial:

I am unable to GET text that is in decoded format. For example:
"file":
"IkdvZCBTYXZlIHRoZSBRdWVlbiIgKGFsdGVybmF0aXZlbHkgIkdvZCBTYXZlIHRoZSBLaW5nIg=="

should be decoded to "God Save the Queen" (alternatively "God Save the
King" but I am getting the same encoded content under _source. I cannot see
the fields even after storing them. Where have I gone wrong?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/15ae700c-ce11-434a-a59d-31381693fae2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You are looking into the _source field which is not modified by elasticsearch.
You need to ask for your stored field at search time. Have a look at fields option in search API.

David

Le 17 nov. 2014 à 06:53, tudit udittumuluri@gmail.com a écrit :

I followed the steps in this tutorial:
https://github.com/elasticsearch/elasticsearch-mapper-attachments/tree/v2.3.2/#version-232-for-elasticsearch-13

I am unable to GET text that is in decoded format. For example:
"file": "IkdvZCBTYXZlIHRoZSBRdWVlbiIgKGFsdGVybmF0aXZlbHkgIkdvZCBTYXZlIHRoZSBLaW5nIg=="

should be decoded to "God Save the Queen" (alternatively "God Save the King" but I am getting the same encoded content under _source. I cannot see the fields even after storing them. Where have I gone wrong?

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/15ae700c-ce11-434a-a59d-31381693fae2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/C317D66B-0BAD-4B1D-8B79-7F76C133B48E%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.