Mapper-attachment plugin not parsing binary files

Hello, having a bit of trouble with mapper-attachments. Elasticsearch.logs
shows plugin loading correctly:
[2013-03-11 09:07:58,407][INFO ][plugins] [Modred the Mystic] loaded
[mapper-attachments], sites []

However, when indexing a binary file with this script:
https://gist.github.com/lukas-vlcek/1075067 (posted in tutorial) nothing
shows up, and when querying by ID, only Base64 data is shown instead of
Tika plain text extraction.

Currently on ES 0.20.5 using .deb installation on debian.

Thanks for your help.

Mitch.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

I tested it some time ago against 0.20 and it was working fine. What version of attachment plugin do you use?
Can you provide a Gist with what you tried so far?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 11 mars 2013 à 15:14, Michel Behlok mbehlok@gmail.com a écrit :

Hello, having a bit of trouble with mapper-attachments. Elasticsearch.logs shows plugin loading correctly:
[2013-03-11 09:07:58,407][INFO ][plugins] [Modred the Mystic] loaded [mapper-attachments], sites []

However, when indexing a binary file with this script: https://gist.github.com/lukas-vlcek/1075067 (posted in tutorial) nothing shows up, and when querying by ID, only Base64 data is shown instead of Tika plain text extraction.

Currently on ES 0.20.5 using .deb installation on debian.

Thanks for your help.

Mitch.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hello David thanks for fast replay. Tried downgrading to 0.20 witch
mapper-attachments 1.7.0 with no luck. Also tried 0.20.5 with MA 1.7-4.0
also with no luck. Here is a Gist as requested:

Mitch

El lunes, 11 de marzo de 2013 10:01:02 UTC-5, David Pilato escribió:

I tested it some time ago against 0.20 and it was working fine. What
version of attachment plugin do you use?
Can you provide a Gist with what you tried so far?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 11 mars 2013 à 15:14, Michel Behlok <mbe...@gmail.com <javascript:>> a
écrit :

Hello, having a bit of trouble with mapper-attachments. Elasticsearch.logs
shows plugin loading correctly:
[2013-03-11 09:07:58,407][INFO ][plugins] [Modred the Mystic] loaded
[mapper-attachments], sites []

However, when indexing a binary file with this script:
https://gist.github.com/lukas-vlcek/1075067 (posted in tutorial) nothing
shows up, and when querying by ID, only Base64 data is shown instead of
Tika plain text extraction.

Currently on ES 0.20.5 using .deb installation on debian.

Thanks for your help.

Mitch.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

also, on 0.20.0 installing plugin directly from .zip local file outputs
this error:

root@debian:/usr/share/elasticsearch/bin# ./plugin -url
file://home/mbehlok/Downloads/elasticsearch-mapper-attachments-1.6.0.zip
-install elasticsearch/elasticsearch-mapper-attachments/1.6.0
-> Installing elasticsearch/elasticsearch-mapper-attachments/1.6.0...
Trying
file://home/mbehlok/Downloads/elasticsearch-mapper-attachments-1.6.0.zip...
Trying
https://github.com/downloads/elasticsearch/elasticsearch-mapper-attachments/elasticsearch-mapper-attachments-1.6.0.zip...
Trying
https://github.com/elasticsearch/elasticsearch-mapper-attachments/zipball/v1.6.0...
Failed to install elasticsearch/elasticsearch-mapper-attachments/1.6.0,
reason: failed to download

El lunes, 11 de marzo de 2013 10:45:20 UTC-5, Michel Behlok escribió:

Hello David thanks for fast replay. Tried downgrading to 0.20 witch
mapper-attachments 1.7.0 with no luck. Also tried 0.20.5 with MA 1.7-4.0
also with no luck. Here is a Gist as requested:

https://gist.github.com/BeWilled/5134964

Mitch

El lunes, 11 de marzo de 2013 10:01:02 UTC-5, David Pilato escribió:

I tested it some time ago against 0.20 and it was working fine. What
version of attachment plugin do you use?
Can you provide a Gist with what you tried so far?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 11 mars 2013 à 15:14, Michel Behlok mbe...@gmail.com a écrit :

Hello, having a bit of trouble with mapper-attachments.
Elasticsearch.logs shows plugin loading correctly:
[2013-03-11 09:07:58,407][INFO ][plugins] [Modred the Mystic] loaded
[mapper-attachments], sites []

However, when indexing a binary file with this script:
https://gist.github.com/lukas-vlcek/1075067 (posted in tutorial) nothing
shows up, and when querying by ID, only Base64 data is shown instead of
Tika plain text extraction.

Currently on ES 0.20.5 using .deb installation on debian.

Thanks for your help.

Mitch.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

URL for file is invalid. Just try to open your PDF and you will see an html page.

curl -C - -O http://www.intersil.com/content/dam/Intersil/documents/fn67/fn6742.pdf

Is the new URL.

I have updated Lukas's script some months ago: https://gist.github.com/dadoonet/3907010

HTH

Note : rm your previous pdf file before running the new gist

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 13 mars 2013 à 20:54, Michel Behlok mbehlok@gmail.com a écrit :

also, on 0.20.0 installing plugin directly from .zip local file outputs this error:

root@debian:/usr/share/elasticsearch/bin# ./plugin -url file://home/mbehlok/Downloads/elasticsearch-mapper-attachments-1.6.0.zip -install elasticsearch/elasticsearch-mapper-attachments/1.6.0
-> Installing elasticsearch/elasticsearch-mapper-attachments/1.6.0...
Trying file://home/mbehlok/Downloads/elasticsearch-mapper-attachments-1.6.0.zip...
Trying https://github.com/downloads/elasticsearch/elasticsearch-mapper-attachments/elasticsearch-mapper-attachments-1.6.0.zip...
Trying https://github.com/elasticsearch/elasticsearch-mapper-attachments/zipball/v1.6.0...
Failed to install elasticsearch/elasticsearch-mapper-attachments/1.6.0, reason: failed to download

El lunes, 11 de marzo de 2013 10:45:20 UTC-5, Michel Behlok escribió:
Hello David thanks for fast replay. Tried downgrading to 0.20 witch mapper-attachments 1.7.0 with no luck. Also tried 0.20.5 with MA 1.7-4.0 also with no luck. Here is a Gist as requested:

https://gist.github.com/BeWilled/5134964

Mitch

El lunes, 11 de marzo de 2013 10:01:02 UTC-5, David Pilato escribió:
I tested it some time ago against 0.20 and it was working fine. What version of attachment plugin do you use?
Can you provide a Gist with what you tried so far?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 11 mars 2013 à 15:14, Michel Behlok mbe...@gmail.com a écrit :

Hello, having a bit of trouble with mapper-attachments. Elasticsearch.logs shows plugin loading correctly:
[2013-03-11 09:07:58,407][INFO ][plugins] [Modred the Mystic] loaded [mapper-attachments], sites []

However, when indexing a binary file with this script: https://gist.github.com/lukas-vlcek/1075067 (posted in tutorial) nothing shows up, and when querying by ID, only Base64 data is shown instead of Tika plain text extraction.

Currently on ES 0.20.5 using .deb installation on debian.

Thanks for your help.

Mitch.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.