Mapper_parsing_exception string


(piter) #1

I use logstash 6.5.0 and elasticsearch 6.4.2

When I try to index some events this is the result:

[2018-11-21T16:27:55,156][WARN ][logstash.outputs.elasticsearch] Could not index event to Elasticsearch. {:status=>400, :action=>["index", {:_id=>"2rPQbSfTngR4Lx/RYseLhwhkMSdDSW/GFxErZoYPoG8=", :_index=>"blue-test", :_type=>"doc", :_routing=>nil}, #LogStash::Event:0xa1cd6dd], :response=>{"index"=>{"_index"=>"blue-test", "_type"=>"doc", "_id"=>"2rPQbSfTngR4Lx/RYseLhwhkMSdDSW/GFxErZoYPoG8=", "status"=>400, "error"=>{"type"=>"mapper_parsing_exception", "reason"=>"failed to find type parsed [string] for [type]"}}}}

What I have do to solve it?


(piter) #2

I used an old template for elasticsearch and I thought that this is the issue. I deleted the template but at the same time the issue is still there.


(piter) #3

I didn't solved yet.
Any help?


(Lewis Barclay) #4

Please post your full config


(piter) #5

Thanks Eniqmatic.
I solved with this changes: