MapperParsingException in More Like This API in 0.90.1

Hi,

After a upgrade of ElasticSearch from version 0.20.5 to 0.90 or 0.90.1, I
started getting a MapperParsingException when I use the More Like This API
for docs with fields of type long. The exception occurs both in the REST
API and Java API (after upgrade, unit tests using Java API started failing).
The exception only occurs using MLT API (MLT queries are working fine, for
example).

Exception returned by REST API:

{

  • error: MapperParsingException[failed to parse [publication_date]];
    nested: ElasticSearchIllegalStateException[Field should have either a
    string, numeric or binary value];
  • status: 400

}

Is this a bug introduced in version 0.90?

Thanks,
Aécio Santos

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

I'm also seeing this issue - in my case, i see it in the Java API only, the
REST API works without error.

It also occurs even when i tell it not to use the 'mapping-error' field in
the mlt calculation...

On Monday, 3 June 2013 15:36:44 UTC+1, Aécio Santos wrote:

Hi,

After a upgrade of ElasticSearch from version 0.20.5 to 0.90 or 0.90.1, I
started getting a MapperParsingException when I use the More Like This
API for docs with fields of type long. The exception occurs both in the
REST API and Java API (after upgrade, unit tests using Java API started
failing).
The exception only occurs using MLT API (MLT queries are working fine, for
example).

Exception returned by REST API:

{

  • error: MapperParsingException[failed to parse [publication_date]];
    nested: ElasticSearchIllegalStateException[Field should have either a
    string, numeric or binary value];
  • status: 400

}

Is this a bug introduced in version 0.90?

Thanks,
Aécio Santos

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Is there any information on this problem? I just started to try More Like
This on our elastic, for a new feature, and have encountered the exact same
results.

On Tuesday, June 25, 2013 2:59:35 AM UTC+12, Derry O' Sullivan wrote:

I'm also seeing this issue - in my case, i see it in the Java API only,
the REST API works without error.

It also occurs even when i tell it not to use the 'mapping-error' field in
the mlt calculation...

On Monday, 3 June 2013 15:36:44 UTC+1, Aécio Santos wrote:

Hi,

After a upgrade of ElasticSearch from version 0.20.5 to 0.90 or 0.90.1,
I started getting a MapperParsingException when I use the More Like This
API for docs with fields of type long. The exception occurs both in the
REST API and Java API (after upgrade, unit tests using Java API started
failing).
The exception only occurs using MLT API (MLT queries are working fine,
for example).

Exception returned by REST API:

{

  • error: MapperParsingException[failed to parse [publication_date]];
    nested: ElasticSearchIllegalStateException[Field should have either a
    string, numeric or binary value];
  • status: 400

}

Is this a bug introduced in version 0.90?

Thanks,
Aécio Santos

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Justin can you recreate this problem or maybe provide a gist that
reproduces it?

simon

On Wednesday, August 7, 2013 12:09:47 AM UTC+2, Justin Israel wrote:

Is there any information on this problem? I just started to try More Like
This on our elastic, for a new feature, and have encountered the exact same
results.

On Tuesday, June 25, 2013 2:59:35 AM UTC+12, Derry O' Sullivan wrote:

I'm also seeing this issue - in my case, i see it in the Java API only,
the REST API works without error.

It also occurs even when i tell it not to use the 'mapping-error' field
in the mlt calculation...

On Monday, 3 June 2013 15:36:44 UTC+1, Aécio Santos wrote:

Hi,

After a upgrade of ElasticSearch from version 0.20.5 to 0.90 or 0.90.1,
I started getting a MapperParsingException when I use the More Like
This API for docs with fields of type long. The exception occurs both
in the REST API and Java API (after upgrade, unit tests using Java API
started failing).
The exception only occurs using MLT API (MLT queries are working fine,
for example).

Exception returned by REST API:

{

  • error: MapperParsingException[failed to parse [publication_date]];
    nested: ElasticSearchIllegalStateException[Field should have either a
    string, numeric or binary value];
  • status: 400

}

Is this a bug introduced in version 0.90?

Thanks,
Aécio Santos

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Sure. Now bear with me because I am brand new to trying out the More Like
This API...

My data set has a mapping with actual date fields in it, but what I did was
just dump a single doc, and started from the ground up by throwing that doc
at a fresh index (which produced a mapping for last_update_time field of
"long"). It came down to simply just the date fields:

$ curl -XDELETE "http://elastic/test"
{"ok":true,"acknowledged":true}

$ curl -XPOST "http://elastic/test/product/" -d '{ "last_update_time":
1367484649580 }'
{"ok":true,"_index":"test","_type":"product","_id":"jxwBp-7QRueAZmInCSW3SA","_version":1}

$ curl -XGET
"http://elastic/test/product/jxwBp-7QRueAZmInCSW3SA/_mlt?min_doc_freq=1"
{"error":"MapperParsingException[failed to parse [last_update_time]];
nested: ElasticSearchIllegalStateException[Field should have either a
string, numeric or binary value]; ","status":400}

Do I need to being taking special preparations around the date fields? Or
this is just a bug similar to what the others in this thread had posted?

On Wednesday, August 7, 2013 5:07:02 PM UTC+12, simonw wrote:

Justin can you recreate this problem or maybe provide a gist that
reproduces it?

simon

On Wednesday, August 7, 2013 12:09:47 AM UTC+2, Justin Israel wrote:

Is there any information on this problem? I just started to try More Like
This on our elastic, for a new feature, and have encountered the exact same
results.

On Tuesday, June 25, 2013 2:59:35 AM UTC+12, Derry O' Sullivan wrote:

I'm also seeing this issue - in my case, i see it in the Java API only,
the REST API works without error.

It also occurs even when i tell it not to use the 'mapping-error' field
in the mlt calculation...

On Monday, 3 June 2013 15:36:44 UTC+1, Aécio Santos wrote:

Hi,

After a upgrade of ElasticSearch from version 0.20.5 to 0.90 or 0.90.1,
I started getting a MapperParsingException when I use the More Like
This API for docs with fields of type long. The exception occurs both
in the REST API and Java API (after upgrade, unit tests using Java API
started failing).
The exception only occurs using MLT API (MLT queries are working fine,
for example).

Exception returned by REST API:

{

  • error: MapperParsingException[failed to parse
    [publication_date]]; nested: ElasticSearchIllegalStateException[Field
    should have either a string, numeric or binary value];
  • status: 400

}

Is this a bug introduced in version 0.90?

Thanks,
Aécio Santos

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

On Wednesday, August 7, 2013 7:40:53 AM UTC+2, Justin Israel wrote:

Sure. Now bear with me because I am brand new to trying out the More Like
This API...

My data set has a mapping with actual date fields in it, but what I did
was just dump a single doc, and started from the ground up by throwing that
doc at a fresh index (which produced a mapping for last_update_time field
of "long"). It came down to simply just the date fields:

$ curl -XDELETE "http://elastic/test"
{"ok":true,"acknowledged":true}

$ curl -XPOST "http://elastic/test/product/" -d '{ "last_update_time":
1367484649580 }'

{"ok":true,"_index":"test","_type":"product","_id":"jxwBp-7QRueAZmInCSW3SA","_version":1}

$ curl -XGET "
http://elastic/test/product/jxwBp-7QRueAZmInCSW3SA/_mlt?min_doc_freq=1"
{"error":"MapperParsingException[failed to parse [last_update_time]];
nested: ElasticSearchIllegalStateException[Field should have either a
string, numeric or binary value]; ","status":400}

Do I need to being taking special preparations around the date fields? Or
this is just a bug similar to what the others in this thread had posted?

Thanks for the recreation... I can reproduce with 0.90.1 but this is fixed
in 0.90.3 so if you use the latest version your problem should go away!

thanks!

simon

On Wednesday, August 7, 2013 5:07:02 PM UTC+12, simonw wrote:

Justin can you recreate this problem or maybe provide a gist that
reproduces it?

simon

On Wednesday, August 7, 2013 12:09:47 AM UTC+2, Justin Israel wrote:

Is there any information on this problem? I just started to try More
Like This on our elastic, for a new feature, and have encountered the exact
same results.

On Tuesday, June 25, 2013 2:59:35 AM UTC+12, Derry O' Sullivan wrote:

I'm also seeing this issue - in my case, i see it in the Java API only,
the REST API works without error.

It also occurs even when i tell it not to use the 'mapping-error' field
in the mlt calculation...

On Monday, 3 June 2013 15:36:44 UTC+1, Aécio Santos wrote:

Hi,

After a upgrade of ElasticSearch from version 0.20.5 to 0.90 or 0.90.1,
I started getting a MapperParsingException when I use the More Like
This API for docs with fields of type long. The exception occurs both
in the REST API and Java API (after upgrade, unit tests using Java API
started failing).
The exception only occurs using MLT API (MLT queries are working fine,
for example).

Exception returned by REST API:

{

  • error: MapperParsingException[failed to parse
    [publication_date]]; nested: ElasticSearchIllegalStateException[Field
    should have either a string, numeric or binary value];
  • status: 400

}

Is this a bug introduced in version 0.90?

Thanks,
Aécio Santos

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Awesome! Thank you so much for confirming. Will try this out tomorrow!
On Aug 7, 2013 9:48 PM, "simonw" simon.willnauer@elasticsearch.com wrote:

On Wednesday, August 7, 2013 7:40:53 AM UTC+2, Justin Israel wrote:

Sure. Now bear with me because I am brand new to trying out the More Like
This API...

My data set has a mapping with actual date fields in it, but what I did
was just dump a single doc, and started from the ground up by throwing that
doc at a fresh index (which produced a mapping for last_update_time field
of "long"). It came down to simply just the date fields:

$ curl -XDELETE "http://elastic/test"
{"ok":true,"acknowledged":**true}

$ curl -XPOST "http://elastic/test/product/" -d '{ "last_update_time":
1367484649580 }'
{"ok":true,"index":"test","type":"product","_id":"jxwBp-
7QRueAZmInCSW3SA","_version":**1}

$ curl -XGET "http://elastic/test/product/*jxwBp-7QRueAZmInCSW3SA/_mlt?
*min_doc_freq=1http://elastic/test/product/jxwBp-7QRueAZmInCSW3SA/_mlt?min_doc_freq=1
"
{"error":"MapperParsingException[failed to parse [last_update_time]];
nested: ElasticSearchIllegalStateExcep
tion[Field should have either a
string, numeric or binary value]; ","status":400}

Do I need to being taking special preparations around the date fields? Or
this is just a bug similar to what the others in this thread had posted?

Thanks for the recreation... I can reproduce with 0.90.1 but this is fixed
in 0.90.3 so if you use the latest version your problem should go away!

thanks!

simon

On Wednesday, August 7, 2013 5:07:02 PM UTC+12, simonw wrote:

Justin can you recreate this problem or maybe provide a gist that
reproduces it?

simon

On Wednesday, August 7, 2013 12:09:47 AM UTC+2, Justin Israel wrote:

Is there any information on this problem? I just started to try More
Like This on our elastic, for a new feature, and have encountered the exact
same results.

On Tuesday, June 25, 2013 2:59:35 AM UTC+12, Derry O' Sullivan wrote:

I'm also seeing this issue - in my case, i see it in the Java API
only, the REST API works without error.

It also occurs even when i tell it not to use the 'mapping-error'
field in the mlt calculation...

On Monday, 3 June 2013 15:36:44 UTC+1, Aécio Santos wrote:

Hi,

After a upgrade of ElasticSearch from version 0.20.5 to 0.90 or 0.90.1,
I started getting a MapperParsingException when I use the More Like
This API for docs with fields of type long. The exception occurs
both in the REST API and Java API (after upgrade, unit tests using Java API
started failing).
The exception only occurs using MLT API (MLT queries are working
fine, for example).

Exception returned by REST API:

{

  • error: MapperParsingException[failed to parse
    [publication_date]]; nested: ElasticSearchIllegalStateExcep
    tion[Field
    should have either a string, numeric or binary value];
  • status: 400

}

Is this a bug introduced in version 0.90?

Thanks,
Aécio Santos

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/ThpaenmPzpM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.