Mapping Conflict in field type


(Sanjeev Ramakrishnan) #1

Hi Team,
I'm facing mapping conflicts while trying to index a data in Elasticsearch.

The data contains a filed with dots like mentioned below

replica.tps.Count: 27359,
sync.tps.FiveMinuteRate: 1101.935848853454,
replicator.buffer.size: 0,
sync.tps.OneMinuteRate: 1377.1610123924681,
replica.tps.FifteenMinuteRate: 4.751466041679348e-45,
replica.status: "AVAILABLE",
sync.tps.MeanRate: 1126.2813387804133,
replica.tps.MeanRate: 0.005062168298549558,
replica.tps.OneMinuteRate: 2.964393875e-314,
replica.tps.FiveMinuteRate: 4.9074475867813965e-135,
sync.tps.FifteenMinuteRate: 624.315144886645,
sync.tps.Count: 798389,
sync.status: "COMPLETE"

And I'm getting the following error

Could not index event to Elasticsearch. {:status=>400, :action=>["index", {:_id=>nil, :_index=>"sample_terracota", :_type=>"doc", :_routing=>nil}, #LogStash::Event:0x1716ca7], :response=>{"index"=>{"_index"=>"sample_terracota", "_type"=>"doc", "_id"=>"dL7RWWcBvluDK8SsM5sl", "status"=>400, "error"=>{"type"=>"illegal_argument_exception", "reason"=>"mapper [\nreplica] of different type, current_type [text], merged_type [ObjectMapper]"}}}}

Is it because of the dots in the fieldname ? Is there any solution or work around for this issue?

Thank you in advance.


#2

have you read the last sentence of the error?because you were already having a type(text), in version 6.x, one index can only have one type


(Sanjeev Ramakrishnan) #3

@zz_hello

Thank you of your response.

I even tried to parse the data with a new index pattern. Even then i was receiving the same error.


#4

i have tried in my pc with es6.4 and there is no problem.here is the code.
PUT test1129/doc/1 { "replica.tps.Count":27359, "sync.tps.FiveMinuteRate": 1101.935848853454, "replicator.buffer.size": 0, "sync.tps.OneMinuteRate": 1377.1610123924681, "replica.tps.FifteenMinuteRate": 4.751466041679348e-45, "replica.status": "AVAILABLE", "sync.tps.MeanRate": 1126.2813387804133, "replica.tps.MeanRate": 0.005062168298549558, "replica.tps.OneMinuteRate": 2.964393875e-314, "replica.tps.FiveMinuteRate": 4.9074475867813965e-135, "sync.tps.FifteenMinuteRate": 624.315144886645, "sync.tps.Count": 798389, "sync.status": "COMPLETE" }


(Sanjeev Ramakrishnan) #5

@zz_hello
That's Weird. Maybe I'll give it an another try and check again whether I'm getting this issue again.