Mappings restore errors

Hello Folks!
I am currently running Elasticsearch v5.5.2 in production, and I am setting up a downsized version in our Staging environment.
I used elasticdump v6.67.1 to dump our mappings and a subset of our data which i am trying to restore into ES in staging, the problem comes that when i run the restore the current message appears:

{"root_cause":[{"type":"mapper_parsing_exception","reason":"Mapping definition for [fields] has unsupported parameters: [fielddata : false]"}],"type":"mapper_parsing_exception","reason":"Mapping definition for [fields] has unsupported parameters: [fielddata : false]"}

I am not sure what the issue maybe, i have tried removing all instances of Fielddata=false in the mappings but i am not sure which mapping is causing the problem. has anyone seen this issue before?

Welcome to our community! :smiley:

5.X has been EOL for quite some time now, please upgrade :slight_smile:

It'd help if you could share the mapping.

1 Like

Sadly we have a legacy app which is running loopback 3, which can't run on ES newer than 5.x. :frowning:
We have a plan to sunset it in the next year, until then I have to keep the Prod one running and setup a Staging version of it for testing purposes.
Regarding the mappings here you go. :smiley:

Any help is appreciated :slight_smile:

Update:
I am able to restore the mappings syncConversations & ConversationMappings sucessfully.
counts and Communications are the mappings that return:

{
    "error": {
        "root_cause": [
            {
                "type": "mapper_parsing_exception",
                "reason": "Mapping definition for [fields] has unsupported parameters:  [fielddata : false]"
            }
        ],
        "type": "mapper_parsing_exception",
        "reason": "Mapping definition for [fields] has unsupported parameters:  [fielddata : false]"
    },
    "status": 400
}