Marvel and basic_auth


(Al Smith) #1

Perhaps a silly question, and yes I've RTFM'd the online documenation - I'd
like to know how to tell Marvel to use a username and password (and
basic_auth) to talk to the ES servers? We have jetty configured to deny
write access without user/pass and of course Marvel needs to know what
those credentials are.

Thanks,
A.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2b645948-79a3-442a-81f6-734a4b015d78%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Boaz Leskes) #2

Hi Al,

try settings the following in your elasticsearch.yml:

marvel.agent.exporter.es.hosts: [ "user:passwd@host:9200" ]

Cheers,
Boaz

On Wednesday, January 29, 2014 3:37:59 PM UTC+1, Al Smith wrote:

Perhaps a silly question, and yes I've RTFM'd the online documenation -
I'd like to know how to tell Marvel to use a username and password (and
basic_auth) to talk to the ES servers? We have jetty configured to deny
write access without user/pass and of course Marvel needs to know what
those credentials are.

Thanks,
A.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f8fad19a-6e0a-49d9-8cc5-01cc03fe11f1%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Al Smith) #3

Thanks Boaz... tried that, and it doesn't seem to want to use the
credentials; from tcpdumping on lo I can see that it wants to do a PUT to
/_template/marvel, doesn't try supplying auth credentials and of course it
gets a 401 back. It doesn't seem to want to retry the request with
authentication credentials.

Regards,
Al.

On Thursday, January 30, 2014 2:15:33 AM UTC+1, Boaz Leskes wrote:

Hi Al,

try settings the following in your elasticsearch.yml:

marvel.agent.exporter.es.hosts: [ "user:passwd@host:9200" ]

Cheers,
Boaz

On Wednesday, January 29, 2014 3:37:59 PM UTC+1, Al Smith wrote:

Perhaps a silly question, and yes I've RTFM'd the online documenation -
I'd like to know how to tell Marvel to use a username and password (and
basic_auth) to talk to the ES servers? We have jetty configured to deny
write access without user/pass and of course Marvel needs to know what
those credentials are.

Thanks,
A.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/22b75ea5-519c-409a-adbd-411d986c52c0%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Boaz Leskes) #4

Hi Al,

This noted and we'll look into it. Thanks for reporting.

Cheers,
Boaz

On Thursday, January 30, 2014 9:24:32 AM UTC+1, Al Smith wrote:

Thanks Boaz... tried that, and it doesn't seem to want to use the
credentials; from tcpdumping on lo I can see that it wants to do a PUT to
/_template/marvel, doesn't try supplying auth credentials and of course it
gets a 401 back. It doesn't seem to want to retry the request with
authentication credentials.

Regards,
Al.

On Thursday, January 30, 2014 2:15:33 AM UTC+1, Boaz Leskes wrote:

Hi Al,

try settings the following in your elasticsearch.yml:

marvel.agent.exporter.es.hosts: [ "user:passwd@host:9200" ]

Cheers,
Boaz

On Wednesday, January 29, 2014 3:37:59 PM UTC+1, Al Smith wrote:

Perhaps a silly question, and yes I've RTFM'd the online documenation -
I'd like to know how to tell Marvel to use a username and password (and
basic_auth) to talk to the ES servers? We have jetty configured to deny
write access without user/pass and of course Marvel needs to know what
those credentials are.

Thanks,
A.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0d781d14-5d05-4555-bf83-9b002a347f7a%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Boaz Leskes) #5

Hey Al,

We just release marvel 1.0.2, which contains support for basic auth for the
data shipping. Can you give it a spin?
See: http://www.elasticsearch.org/guide/en/marvel/current/#configuration

Cheers,
Boaz

On Thursday, January 30, 2014 11:59:00 AM UTC+1, Boaz Leskes wrote:

Hi Al,

This noted and we'll look into it. Thanks for reporting.

Cheers,
Boaz

On Thursday, January 30, 2014 9:24:32 AM UTC+1, Al Smith wrote:

Thanks Boaz... tried that, and it doesn't seem to want to use the
credentials; from tcpdumping on lo I can see that it wants to do a PUT to
/_template/marvel, doesn't try supplying auth credentials and of course it
gets a 401 back. It doesn't seem to want to retry the request with
authentication credentials.

Regards,
Al.

On Thursday, January 30, 2014 2:15:33 AM UTC+1, Boaz Leskes wrote:

Hi Al,

try settings the following in your elasticsearch.yml:

marvel.agent.exporter.es.hosts: [ "user:passwd@host:9200" ]

Cheers,
Boaz

On Wednesday, January 29, 2014 3:37:59 PM UTC+1, Al Smith wrote:

Perhaps a silly question, and yes I've RTFM'd the online documenation -
I'd like to know how to tell Marvel to use a username and password (and
basic_auth) to talk to the ES servers? We have jetty configured to deny
write access without user/pass and of course Marvel needs to know what
those credentials are.

Thanks,
A.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/76e7421d-bfcd-47fe-b691-7b5d33ecb867%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Al Smith) #6

Works great - thanks for the quick turnaround!

Regards,
Al.

---- Original message ----

From: Boaz Leskes
To: elasticsearch@googlegroups.com
Cc:
Date: 04/02/2014 16:59:00
Subject: Re: Marvel and basic_auth

Hey Al,

We just release marvel 1.0.2, which contains support for basic auth for the
data shipping. Can you give it a spin?
See: http://www.elasticsearch.org/guide/en/marvel/current/#configuration

Cheers,
Boaz

On Thursday, January 30, 2014 11:59:00 AM UTC+1, Boaz Leskes wrote:

Hi Al,

This noted and we'll look into it. Thanks for reporting.

Cheers,
Boaz

On Thursday, January 30, 2014 9:24:32 AM UTC+1, Al Smith wrote:

Thanks Boaz... tried that, and it doesn't seem to want to use the
credentials; from tcpdumping on lo I can see that it wants to do a PUT to
/_template/marvel, doesn't try supplying auth credentials and of course it
gets a 401 back. It doesn't seem to want to retry the request with
authentication credentials.

Regards,
Al.

On Thursday, January 30, 2014 2:15:33 AM UTC+1, Boaz Leskes wrote:

Hi Al,

try settings the following in your elasticsearch.yml:

marvel.agent.exporter.es.hosts: [ "user:passwd@host:9200" ]

Cheers,
Boaz

On Wednesday, January 29, 2014 3:37:59 PM UTC+1, Al Smith wrote:

Perhaps a silly question, and yes I've RTFM'd the online documenation -
I'd like to know how to tell Marvel to use a username and password (and
basic_auth) to talk to the ES servers? We have jetty configured to deny
write access without user/pass and of course Marvel needs to know what
those credentials are.

Thanks,
A.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/1ScH7sTV6kU/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/76e7421d-bfcd-47fe-b691-7b5d33ecb867%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/alpine.WNT.2.00.1402111449450.18840%40ajsmith1-w7.nbttech.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #7