Marvel To Xpack


(ONE) #1

Hello,

We have successfully managed to create a bunch of elastic snapshots and restores (fully tested and working). We are now in the phase to move to 1.7.3 to 6.0.0.

Doing this we need to move Marvel to XPack. We do not know where to start... Any advice?


(Mark Walkom) #2

What upgrade process are you taking?


(ONE) #3

Not sure what you mean...

Well, the steps I'll be doing is:

Moving 1.7.3 to 2.0 then,
2.0 to 5.0 then,
5.0 to 6.0.

I haven't thought of the process on moving the marvel to xpack...


(Mark Walkom) #4

When you go from 2>5 you will need to reinstall the plugins. Instead of installing Marvel you just install X-Pack.


(ONE) #5

Would that just work :open_mouth:

What about the marvel indices??


(Mark Walkom) #6

I'd just delete them.


(ONE) #7

ok that is great to hear!!

I will test this out tomorrow :slight_smile:

Thank you for the help!


(Tim Vernum) #8

There's a specific page for upgrading from Marvel 2.x to X-Pack 5.x that you should read

https://www.elastic.co/guide/en/x-pack/5.6/migrating_from_marvel.html


(system) #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.