Master can not be discovered

After i enabled
xpack.security.enabled: true
xpack.security.transport.ssl.enabled: true
and i restart my two nodes i get this error
master not discovered yet, this node has not previously joined a bootstrapped (v7+) cluster, and this node must discover master-eligible nodes [digisvcnode-1] to bootstrap a cluster: have discovered
without this two enabled the two nodes works perfectly

Please format your codes and errors under preformatted text </> or backticks (```) as sometimes it could be hard to read.

If you set above to true, you will have to put in the certs and update elastic nodes' hosts with https including your

Below link might able to give u a better idea on where and what needs to be done:

Hope this can help you!

hello
thanks for the article after setting up ssl this error pops up
http client did not trust this server's certificate, closing connection Netty4HttpChannel

Where did this error shows? elasticsearch? or other components?

To have a better understanding of the issue, could you share the elasticsearch.yml?

format codes and errors under preformatted text </> or backticks (```) as it could be hard to read otherwise sometimes.

# ======================== Elasticsearch Configuration =========================
#
# NOTE: Elasticsearch comes with reasonable defaults for most settings.
#       Before you set out to tweak and tune the configuration, make sure you
#       understand what are you trying to accomplish and the consequences.
#
# The primary way of configuring a node is via this file. This template lists
# the most important settings you may want to configure for a production cluster.
#
# Please consult the documentation for further information on configuration options:
# https://www.elastic.co/guide/en/elasticsearch/reference/index.html
#
# ---------------------------------- Cluster -----------------------------------
#
# Use a descriptive name for your cluster:
#
cluster.name: DigisvcElasticSearch_1
xpack.security.enabled: true
xpack.security.transport.ssl.enabled: true
xpack.security.transport.ssl.verification_mode: certificate
xpack.security.transport.ssl.keystore.path: /etc/config/elastic-certificates.p12
xpack.security.transport.ssl.truststore.path: /etc/config/elastic-certificates.p12
xpack.security.http.ssl.enabled: true
xpack.security.http.ssl.keystore.path: "/etc/config/http.p12"
#
# ------------------------------------ Node ------------------------------------
#
# Use a descriptive name for the node:
#
node.master: true
node.data: true
node.name: digisvcnode-1
#
# Add custom attributes to the node:
#
#node.attr.rack: r1
#
# ----------------------------------- Paths ------------------------------------
#
# Path to directory where to store the data (separate multiple locations by comma):
#
path.data: etc\data
#
# Path to log files:
#
path.logs: etc\logs
#
# ----------------------------------- Memory -----------------------------------
#
# Lock the memory on startup:
#
#bootstrap.memory_lock: true
#
# Make sure that the heap size is set to about half the memory available
# on the system and that the owner of the process is allowed to use this
# limit.
#
# Elasticsearch performs poorly when the system is swapping the memory.
#
# ---------------------------------- Network -----------------------------------
#
# Set the bind address to a specific IP (IPv4 or IPv6):
#
#transport.host: localhost 
#transport.tcp.port: 9300 
network.host: ip
#network.host: 192.168.0.1
#
# Set a custom port for HTTP:
#
http.port: port
#
# For more information, consult the network module documentation.
#
# --------------------------------- Discovery ----------------------------------
#
# Pass an initial list of hosts to perform discovery when this node is started:
# The default list of hosts is ["127.0.0.1", "[::1]"]
#
discovery.zen.minimum_master_nodes: 1
discovery.seed_hosts: ["ip"]
bootstrap.system_call_filter: false
#
# Prevent the "split brain" by configuring the majority of nodes (total number of master-eligible nodes / 2 + 1):
# 
# Bootstrap the cluster using an initial set of master-eligible nodes:
#
cluster.initial_master_nodes: ["digisvcnode-1"]
#
# For more information, consult the discovery and cluster formation module documentation.
#
# ---------------------------------- Gateway -----------------------------------
#
# Block initial recovery after a full cluster restart until N nodes are started:
#
#gateway.recover_after_nodes: 3
#
# For more information, consult the gateway module documentation.
#
# ---------------------------------- Various -----------------------------------
#
# Require explicit names when deleting indices:
#
#action.destructive_requires_name: true

I just saw that this is a 2-node cluster, there are some recommendation from here about using 2-nodes cluster you might wanna read it up.

When you turn on security and ssl, did your another node have the configured the same too?

i have the same security and ssl configuration for the other node