Match_pattern mapping doesn't work


#1

I'm trying to create a template to map my futur indices.
The following match work fine:

"mappings": {
"doc": {
  "properties": {
    "@version": {
      "enabled": false
    },
    "tags": {
        "enabled": false
    }
  },
  "dynamic_templates": [
    {
      "number_template": {
        "match": "A*",
        "mapping": {
          "type": "float"
        }
      }
    }
  ]
}
}

But I want more field starting with other letter so I try to use the "match_pattern" with "regex".

"mappings": {
"doc": {
  "properties": {
    "@version": {
      "enabled": false
    },
    "tags": {
        "enabled": false
    }
  },
  "dynamic_templates": [
    {
      "number_template": {
        "match_pattern": "regex",
        "match": "A*",
        "mapping": {
          "type": "float"
        }
      }
    }
  ]
}
}

But it doesn't work. I would like something like this "[AT]*", but it seems that there is something wrong somewhere.


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.