Max number of values in term query


(narinder.izap) #1

Hi Shay,
I need to get all of the document with the given set of ids. and
the set size is about 2000. if I am trying to send the whole set, its not
working. Its not picking values more than 1024. Is there any setting which
can increase this limit, so that i can send all of the ids and get all of
the documents???

Thanks.

--


(Radu Gheorghe) #2

Hello Narinder,

Do you use the Multi Get API?
http://www.elasticsearch.org/guide/reference/api/multi-get.html

Because with that, for me it works:

for i in {1..2000}; do curl -XPUT localhost:9200/test/multi/$i -d

'{"foo":"bar'"$i"'"}'; done

ARRAY="["; for i in {1..1999}; do ARRAY="$ARRAY"$i", "; done;

ARRAY="$ARRAY"$(($i+1))"]";curl
localhost:9200/test/multi/_mget?pretty=true -d '{"ids":'"$ARRAY"'}'

And it prints out all the documents, as far as I can see.

Best regards,
Radu

http://sematext.com/ -- ElasticSearch -- Solr -- Lucene

On Fri, Oct 26, 2012 at 7:49 AM, Narinder Kaur narinder.kaur@izap.in wrote:

Hi Shay,
I need to get all of the document with the given set of ids. and
the set size is about 2000. if I am trying to send the whole set, its not
working. Its not picking values more than 1024. Is there any setting which
can increase this limit, so that i can send all of the ids and get all of
the documents???

Thanks.

--

--


(Igor Motov) #3

You can change this limit using "indices.query.bool.max_clause_count"
setting.

On Friday, October 26, 2012 12:49:22 AM UTC-4, Narinder Kaur wrote:

Hi Shay,
I need to get all of the document with the given set of ids.
and the set size is about 2000. if I am trying to send the whole set, its
not working. Its not picking values more than 1024. Is there any setting
which can increase this limit, so that i can send all of the ids and get
all of the documents???

Thanks.

--


(system) #4