Max_result_window ignored


#1

I'm using Elasticsearch 2.4.6. I've changed index.max_result_window to a lower number, but ES keeps returning everything that matches. Is there another way to limit the number of results?


(Thiago Souza) #2

That setting controls the limit for from + size parameters of a query. If you want to change the count of documents a query returns you need to change the size parameter of a query (defaults to 10)


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.