Merge cannot catch up with updates


(Vincent) #1

I have a very busy cluster and using defined _id instead of auto. So there are a lot of updates on existing documents. I see from _stats endpoint that the ratio between deleted document and total document is at 70% and still growing over days. I'm guessing the merge operations cannot catch up with the updates speed.

I've increased the setting index.merge.scheduler.max_thread_count but don't see noticeable improvement. I think that's the max but not how many current runs.

Is there any other configuration I can do to have the merge happens more frequent or faster?

Appreciate your help!


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.