Merge Size increased by 600 GB

Mapping Json

{
"number_of_shards": 4,
"number_of_replicas": 1,
"analysis": {
"analyzer": {
"indexAnalyzer": {
"type": "custom",
"tokenizer": "standard",
"filter": [
"lowercase",
"mySnowball"
]
},
"searchAnalyzer": {
"type": "custom",
"tokenizer": "standard",
"filter": [
"standard",
"lowercase",
"mySnowball"
]
},
"suggest_analyzer": {
"type": "custom",
"tokenizer": "standard",
"filter": [
"standard",
"lowercase",
"my_shingle"
],
"char_filter": "html_strip"
},
"cb_tag_analyzer": {
"type": "custom",
"tokenizer": "semicolon_token"
}
},
"filter": {
"mySnowball": {
"type": "snowball",
"language": "English"
},
"my_ngram": {
"type": "edgeNGram",
"min_gram": 2,
"max_gram": 50,
"side": "front"
},
"my_shingle": {
"type": "shingle",
"min_shingle_sizes": 2,
"max_shingle_size": 50,
"side": "front"
}
},
"tokenizer": {
"semicolon_token": {
"type": "pattern",
"pattern": ","
}
}
}
}{
"suggest": {
"index_analyzer": "indexAnalyzer",
"search_analyzer": "searchAnalyzer",
"_boost": {
"name": "_boost",
"null_value": 1
},
"properties": {
"title": {
"type": "multi_field",
"include_in_all": true,
"fields": {
"title": {
"type": "string",
"index": "not_analyzed"
},
"suggest": {
"type": "string",
"analyzer": "suggest_analyzer"
}
}
},
"_boost": {
"type": "float",
"include_in_all": false
}
}
}
}{
"videos": {
"index_analyzer": "indexAnalyzer",
"search_analyzer": "searchAnalyzer",
"_boost": {
"name": "_boost",
"null_value": 1
},
"properties": {
"videoid": {
"type": "integer",
"include_in_all": false
},
"title": {
"type": "multi_field",
"include_in_all": true,
"fields": {
"title": {
"type": "string",
"index": "not_analyzed"
},
"suggest": {
"type": "string",
"analyzer": "suggest_analyzer"
}
}
},
"tags": {
"type": "multi_field",
"include_in_all": true,
"fields": {
"tags": {
"type": "string",
"analyzer": "cb_tag_analyzer"
}
}
},
"description": {
"type": "string",
"include_in_all": true
},
"date_added": {
"type": "date",
"include_in_all": true,
"format": "YYYY-MM-dd HH:mm:ss"
},
"status": {
"type": "string",
"include_in_all": true
},
"broadcast": {
"type": "string",
"include_in_all": true
},
"userid": {
"type": "integer",
"include_in_all": false
},
"duration": {
"type": "float",
"include_in_all": true
},
"username": {
"type": "string",
"include_in_all": true
},
"_boost": {
"type": "float",
"include_in_all": false
}
}
}
}

I did refresh document on indexing before but it has been stopped from a
long time, at that time merge size was around 60Gig and now it has Jumped
to 600GB , please tell me what could be wrong?

I have not changed any merge policy, should i change it now?

Index tune
size: 205.3mb (412.3mb)
docs: 195179 (223489)

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

On Wednesday, May 29, 2013 5:44:52 PM UTC+5, Arslan Hassan wrote:

Mapping Json

{
"number_of_shards": 4,
"number_of_replicas": 1,
"analysis": {
"analyzer": {
"indexAnalyzer": {
"type": "custom",
"tokenizer": "standard",
"filter": [
"lowercase",
"mySnowball"
]
},
"searchAnalyzer": {
"type": "custom",
"tokenizer": "standard",
"filter": [
"standard",
"lowercase",
"mySnowball"
]
},
"suggest_analyzer": {
"type": "custom",
"tokenizer": "standard",
"filter": [
"standard",
"lowercase",
"my_shingle"
],
"char_filter": "html_strip"
},
"cb_tag_analyzer": {
"type": "custom",
"tokenizer": "semicolon_token"
}
},
"filter": {
"mySnowball": {
"type": "snowball",
"language": "English"
},
"my_ngram": {
"type": "edgeNGram",
"min_gram": 2,
"max_gram": 50,
"side": "front"
},
"my_shingle": {
"type": "shingle",
"min_shingle_sizes": 2,
"max_shingle_size": 50,
"side": "front"
}
},
"tokenizer": {
"semicolon_token": {
"type": "pattern",
"pattern": ","
}
}
}
}{
"suggest": {
"index_analyzer": "indexAnalyzer",
"search_analyzer": "searchAnalyzer",
"_boost": {
"name": "_boost",
"null_value": 1
},
"properties": {
"title": {
"type": "multi_field",
"include_in_all": true,
"fields": {
"title": {
"type": "string",
"index": "not_analyzed"
},
"suggest": {
"type": "string",
"analyzer": "suggest_analyzer"
}
}
},
"_boost": {
"type": "float",
"include_in_all": false
}
}
}
}{
"videos": {
"index_analyzer": "indexAnalyzer",
"search_analyzer": "searchAnalyzer",
"_boost": {
"name": "_boost",
"null_value": 1
},
"properties": {
"videoid": {
"type": "integer",
"include_in_all": false
},
"title": {
"type": "multi_field",
"include_in_all": true,
"fields": {
"title": {
"type": "string",
"index": "not_analyzed"
},
"suggest": {
"type": "string",
"analyzer": "suggest_analyzer"
}
}
},
"tags": {
"type": "multi_field",
"include_in_all": true,
"fields": {
"tags": {
"type": "string",
"analyzer": "cb_tag_analyzer"
}
}
},
"description": {
"type": "string",
"include_in_all": true
},
"date_added": {
"type": "date",
"include_in_all": true,
"format": "YYYY-MM-dd HH:mm:ss"
},
"status": {
"type": "string",
"include_in_all": true
},
"broadcast": {
"type": "string",
"include_in_all": true
},
"userid": {
"type": "integer",
"include_in_all": false
},
"duration": {
"type": "float",
"include_in_all": true
},
"username": {
"type": "string",
"include_in_all": true
},
"_boost": {
"type": "float",
"include_in_all": false
}
}
}
}

I did refresh document on indexing before but it has been stopped from a
long time, at that time merge size was around 60Gig and now it has Jumped
to 600GB , please tell me what could be wrong?

I have not changed any merge policy, should i change it now?

Index tune
size: 205.3mb (412.3mb)
docs: 195179 (223489)

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.